Filter Articles in Need of Review by Localization

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: scott, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:change])

(Reporter)

Description

5 years ago
What feature should be changed? Please provide the URL of the feature if possible.
==================================================================================
List of articles in need of review:
(Editorial) URL: https://developer.mozilla.org/en-US/docs/needs-review/editorial
(Technical) URL: https://developer.mozilla.org/en-US/docs/needs-review/technical

Should display articles, by default, within just the user's current localization namespace (en-US, etc.). 

A button or link, "show all localizations", could temporarily restore current, unfiltered, results if demand exists. I could see some (occasional) benefit to monitoring all localizations, just not by default.

What problems would this solve?
===============================
This feature change would allow volunteers and staff to easily access only the articles in localizations which they can assist with. This is especially useful for contributors to uncommon languages which could get buried.

Who would use this?
===================
Contributors (community and employees) who edit Mozilla Developer Network.

What would users see?
=====================
Less localizations they are unable to contribute to.

What would users do? What would happen as a result?
===================================================
Select the localization they wish to review articles from. A potential shortcoming is that users who can contribute to multiple localizations might favour their default language. Although, again, a "see all localizations" link would assist at least as effectively.

Is there anything else we should know?
======================================
(Reporter)

Updated

5 years ago
Component: General → Collaboration
OS: Other → All
I think this is a dupe, but it's a very important point.
I fixed this.
https://github.com/mozilla/kuma/pull/2141

Should be on prod soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.