Mouse hover effect offset

VERIFIED FIXED in Firefox 25

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: saad.inam92, Assigned: kats)

Tracking

25 Branch
Firefox 27
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 fixed, firefox26 verified, firefox27 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0 (Beta/Release)
Build ID: 20131001023928

Steps to reproduce:

USing the HP slatebook x2 dock (keyboard and mouse) I open any web page (in firefox beta).
I move my mouse pointer over something that should have a hover effect(like a drop down menu), but it doesnt open, or have its effect. If I move my mouse lower and to the right, the hover effect on an item displays. i.e. the trigger for the hover effect is missplaced significantly to the top left. 


Actual results:

The hover effect did not trigger when I hovered my mouse over a drop down menu, or any other item that has a hover effect. Only when I lowered the point to the right and down, the hover effect triggered.


Expected results:

When I place my mouse ponter over an item with a hover effect, it should be triggered.
OS: Linux → Android
Hardware: x86_64 → HP
This shows that when the pointer is placed below and to the right of the home like, the hover effect of the link is activated. Hovering the cursor over the home link does not do this.
Hardware: HP → ARM
Posted patch PatchSplinter Review
Here's one that compiles. Untested though since I don't have a device that accepts mouse input.

https://tbpl.mozilla.org/?tree=Try&rev=1710ee55568d
Assignee: nobody → bugmail.mozilla
Attachment #815310 - Attachment is obsolete: true
Attachment #815378 - Flags: review?(wjohnston)
Hi saad, can you verify that the build at [1] fixes the problem? You should be able to install the build on your device if you check the option to allow untrusted app sources in the Android settings. The build will show up on your device as "Nightly" and will be separate from your Firefox Beta install. You can uninstall Nightly after you're done without affecting your existing Firefox Beta app or profile.

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-1710ee55568d/try-android/fennec-27.0a1.en-US.android-arm.apk
Flags: needinfo?(saad.inam92)
Comfirmed working!

Tested on different websites, passed 100%.

Great work, Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(saad.inam92)
Resolution: --- → WORKSFORME
Thanks for confirming. The patch isn't in the tree yet, but we will mark this bug fixed once it lands.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
I'll try to reivew Monday (I have a machine that can take a mouse there).
Attachment #815378 - Flags: review?(wjohnston) → review+
Comment on attachment 815378 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 803207
User impact if declined: In Fennec, if a mouse is attached the hover events are sent to the wrong position on hi-dpi devices
Testing completed (on m-c, etc.): on m-c, verified by reporter and wesj
Risk to taking this patch (and alternatives if risky): fairly low risk - i understand the code well and there's a pretty low chance of unintended side effects. It affects Fennec only.
String or IDL/UUID changes made by this patch: none
Attachment #815378 - Flags: approval-mozilla-beta?
Attachment #815378 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/43807e2ed283
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 815378 [details] [diff] [review]
Patch

We'll take this because:

1) it's a 25 regression in mobile and we should avoid
2) if it regresses mouse ability further, we wouldn't chemspill
Attachment #815378 - Flags: approval-mozilla-beta?
Attachment #815378 - Flags: approval-mozilla-beta+
Attachment #815378 - Flags: approval-mozilla-aurora?
Attachment #815378 - Flags: approval-mozilla-aurora+
Has merge conflicts with Aurora. Please attach a branch-specific patch for uplift.
Flags: needinfo?(bugmail.mozilla)
Verified with a Micro USB OTG dongle and USB mouse, this now works.
Status: RESOLVED → VERIFIED
Depends on: 961612
You need to log in before you can comment on or make changes to this bug.