"StateString”:identifier not found

RESOLVED DUPLICATE of bug 925705

Status

()

RESOLVED DUPLICATE of bug 925705
5 years ago
5 years ago

People

(Reporter: c, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20131007194344

Steps to reproduce:

 disable moz_logging, CacheEntry.cpp(164) : error C3861: "StateString”:identifier not found.

Updated

5 years ago
Component: Build Config → Networking: Cache

Comment 1

5 years ago
Same in 27.0a1 branch

With or without disabling moz_logging

./netwerk/cache2/CacheEntry.cpp(164) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(456) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(544) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(615) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(1018) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(1032) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(1059) : Error C3861 'StateString': Identifier not found
./netwerk/cache2/CacheEntry.cpp(1216) : Error C3861 'StateString': Identifier not found

CacheEntry.cpp Failed, Return code 1

<nkcache2_s.lib.desc>: Found Error

Make.py Libs Failed, return code 2

Comment 2

5 years ago
Modifying  ./netwerk/cache2/CacheEntry.h Line:(245)

#ifdef MOZ_LOGGING
  static char const * StateString(uint32_t aState);
#endif

Changing it to:

#ifdef MOZ_LOGGING
  static char const * StateString(uint32_t aState);
#else
static char const * StateString(uint32_t aState);
#endif

Seems to fix the issue probably not the best patch but its working.

Successfully compile with moz_logging enabled/disabled
(Reporter)

Comment 3

5 years ago
(In reply to Toady from comment #2)
> Modifying  ./netwerk/cache2/CacheEntry.h Line:(245)
> 
> #ifdef MOZ_LOGGING
>   static char const * StateString(uint32_t aState);
> #endif
> 
> Changing it to:
> 
> #ifdef MOZ_LOGGING
>   static char const * StateString(uint32_t aState);
> #else
> static char const * StateString(uint32_t aState);
> #endif
> 
> Seems to fix the issue probably not the best patch but its working.
> 
> Successfully compile with moz_logging enabled/disabled

just remove the #if #endif shall make it work

Comment 4

5 years ago
This issue has been fixed https://bugzilla.mozilla.org/show_bug.cgi?id=925705
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925705
You need to log in before you can comment on or make changes to this bug.