Closed Bug 924865 Opened 6 years ago Closed 6 years ago

Excessive redraw causing flickering when viewing messages

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 923309

People

(Reporter: darren.p.kenny, Unassigned)

Details

(Keywords: regression, Whiteboard: [regression:TB??])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1659.2 Safari/537.36

Steps to reproduce:

After updating to the latest Daily build from 2013-10-07, and subsequent updates, I'm seeing excessive flickering when viewing messages. 

Just changing focus to/from TB you can see the flickering. 

This is on MacOS 10.7 (Lion), no other application is exhibiting this behaviour.


FYI, still see this on latest nightly of 2013-10-09:

Name 	Thunderbird
Version 	27.0a1
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:27.0) Gecko/20100101 Thunderbird/27.0a1
Application Build ID 	20131009030201



Actual results:

Just viewing messages is enough to give you a headache.

You can see the flickering even when the message pane is empty, with no message displayed. 

It looks like the message pane is split in two, with most of the flickering on the right side.


Expected results:

Shouldn't be seeing this kind of flickering.
Yep, definitely an issue. Would be helpful to get a regression range though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
When you say regression range, what do you mean - do you mean between when I didn't see it and when I did?

Is there a way to see the update history? 

Doing a grep '^.*mozilla\.daily.*Thunderbird.*2013\(09\|10\)' on the system.log files would appear to give me:

system.log:Oct  9 10:32:22 <HOSTNAME> [0x0-0x13c13c].org.mozilla.daily[4868]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20131008030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/19/570/1/
system.log.0:Oct  8 10:32:23 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[0]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20131007030202/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/18/569/1/
system.log.1:Oct  6 18:27:34 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/17/568/1/
system.log.2:Oct  5 18:27:35 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/16/567/1/
system.log.3:Oct  4 18:27:34 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/15/566/1/
system.log.4:Oct  2 15:49:00 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/13/564/1/
system.log.4:Oct  3 18:27:34 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/14/565/1/
system.log.5:Oct  1 15:49:01 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/12/563/1/
system.log.6:Sep 30 14:47:00 <HOSTNAME> [0x0-0xcefcef].org.mozilla.daily[64642]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/11/562/1/
system.log.6:Sep 30 15:49:00 <HOSTNAME> [0x0-0xd02d02].org.mozilla.daily[64762]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130929030203/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/11/562/1/
system.log.7:Sep 29 14:40:04 darren-kennys-macbook-2 [0x0-0xa97a97].org.mozilla.daily[0]: *** Blocklist::notify: Requesting https://addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/27.0a1/Thunderbird/20130927030202/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2011.4.2/default/default/10/561/1/

So I believe that this points at me doing an update from 20130929 to 20131007. 

Unfortunately I can't seem to narrow it down any more than that.
That's exactly what I meant. :) And what you have is pretty helpful actually. But for even narrower results, I suggest https://github.com/mozilla/mozregression to get a better regression range.

Just remember the --app=thunderbird argument. Though I see the issue too, so if you don't get a chance to do this today, I will later.
Keywords: regression
also seeing excessive flickering in message window

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Thunderbird/27.0a1 ID:20131009030201 CSet: 01c56e89552c
Summary: Excessive redraw causing flckering when viewing messages → Excessive redraw causing flickering when viewing messages
Whiteboard: [regression:TB??]
Fixed by bug 923309. Duping.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923309
You need to log in before you can comment on or make changes to this bug.