Closed Bug 924889 Opened 6 years ago Closed 6 years ago

Defect - Installer does not register metro app when Firefox is already installed

Categories

(Firefox for Metro Graveyard :: Install/Update, defect, P2)

x86_64
Windows 8
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: desiradaniel2007, Assigned: TimAbraldes)

Details

I have installed Firefox Nightly builds on Windows 8 after installing the latest stable release of Firefox. Clicking on app's tile in Metro launches it in desktop mode.

I have already made Nightly my default browser, uninstalled both versions of Firefox and reinstalled Nightly by itself and spoke to a paid contributor, whom I met at the Brussels summit and has pointed me to file a bug.

Please let me know when any more troubleshooting is required.
Summary: Installer does not register metro app when Firefox is already installed → Defect - Installer does not register metro app when Firefox is already installed
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
:bbondy, any direction for the report or data to pull from the machine to investigate?
Flags: needinfo?(netzen)
Let's try to reproduce this ourselves with multi installs. Juan can you help here?
Flags: needinfo?(netzen) → needinfo?(jbecerra)
I can reproduce this if, having installed a release version, I install the nightly and don't opt to make it my default browser. If I opt in to the Firefox and the Windows prompts to make it my default browser, then clicking on the tile opens it in Metro mode.
Flags: needinfo?(jbecerra)
Whiteboard: feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=0
Blocks: 935467
Whiteboard: [block28] feature=defect c=tbd u=tbd p=0 → [release28] feature=defect c=tbd u=tbd p=0
Whiteboard: [release28] feature=defect c=tbd u=tbd p=0 → [beta28] feature=defect c=tbd u=tbd p=0
Assignee: nobody → tabraldes
Blocks: metrov1it21
No longer blocks: metrov1backlog
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
QA Contact: jbecerra
I'm revising comment #3 to make it a little clearer. Tested on 2013-12-09 with latest 25.0.1 and latest Nightly.

Steps:
1. Install 25.0.1 and launch it.
2. Make it your default browser when the Firefox prompt comes up, as well as when the OS prompt comes up.
(side note: no tile is created in the Start page, but there's a tiny tile in the list of all apps installed)
3. Go to nightly.mozilla.org and download and install the Nightly, closing Firefox 25.0.1 first.
4. Make it your default browser when the Nightly prompt comes up, as well as when the OS prompt comes up.
(notice a Nightly tile is added in the Start page)
5. Close the Nightly.
6. Go to the Start page and click on the Nightly tile.

Expected: The nightly launches in Metro mode.

Actual: It launches nightly in desktop mode.
I tried the following to reproduce:
  1. Installed Firefox
  2. Set all of Firefox's defaults
  3. Installed Nightly
  4. Set all of Nightly's defaults
  5. Launched Nightly

These days, Nightly no longer launches in metro mode by default; it launches in whatever mode was last launched. Because I'm testing with a brand new Nightly, and the most recent browser I'd used before launching Nightly was desktop Firefox, I expect Nightly to always launch in desktop mode. From desktop Nightly I can select the "Windows 8 Touch" button from the Australis menu to switch over to metro mode.

Juan or original reporter - does the above match your findings/expectations? If so, I think we can go ahead and close this bug.
Flags: needinfo?(desiradaniel2007)
Flags: needinfo?(jbecerra)
Based on recent conversation in #windev, I'm resolving this bug. It seems to describe what is now expected behavior (though wasn't expected behavior when the bug was filed; go figure!)

The expected behavior is that the first time you launch any metro-enabled Firefox, it will launch in Desktop mode. Any subsequent launch will launch in whatever mode was most recently used. From desktop mode, you can enter metro mode by using the "Windows 8 Touch" button in the Australis menu. There is (or will be) a similar mechanism for going from metro to desktop mode.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jbecerra)
Flags: needinfo?(desiradaniel2007)
Resolution: --- → WORKSFORME
No longer blocks: 935467, metrov1it21
Whiteboard: [beta28] feature=defect c=tbd u=tbd p=0
You need to log in before you can comment on or make changes to this bug.