[Contacts] Javascript error after landing bug 902873 (merge error)

RESOLVED FIXED in Firefox OS v1.2

Status

Firefox OS
Gaia::Contacts
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: arcturus, Assigned: arcturus)

Tracking

({perf})

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [c= p= s= u=1.2])

Attachments

(1 attachment)

We recently landed the performance improvements in bug 902873.

After a rebase, the functionality is there but we can see the error:

JavaScript error: http://communications.gaiamobile.org:8080/contacts/js/views/list.js, line 1464: notSelecteIds is not defined

This has been caused by a rebase in order to land
Nominating for koi since has been caused by the merge of a koi+ code.
Assignee: nobody → francisco.jordano
blocking-b2g: --- → koi?
Whiteboard: [c= p=4 s= u=1.2]

Comment 2

4 years ago
Looks like a one character typo?  s/notSelecteIds/notSelectedIds/g ?
right, simple fix
Created attachment 814932 [details]
Pointer to PR 12756
Attachment #814932 - Flags: review?(bkelly)

Updated

4 years ago
Attachment #814932 - Flags: review?(bkelly) → review+

Updated

4 years ago
Status: NEW → ASSIGNED
blocking-b2g: koi? → koi+
Keywords: perf
OS: Mac OS X → Gonk (Firefox OS)
Priority: -- → P1
Hardware: x86 → ARM
Landed:

https://github.com/mozilla-b2g/gaia/commit/f4514d1de0d008eda71f9784e78798bf8ad09110
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 1.2 C2(Oct11)

Updated

4 years ago
Whiteboard: [c= p=4 s= u=1.2] → [c= p=4 s=2013.10.18 u=1.2]
Target Milestone: 1.2 C2(Oct11) → 1.2 C3(Oct25)

Updated

4 years ago
Whiteboard: [c= p=4 s=2013.10.18 u=1.2] → [c= p=4 s= u=1.2]
I was not able to uplift this bug to v1.2.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.2, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.2
  git cherry-pick -x -m1 f4514d1de0d008eda71f9784e78798bf8ad09110
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(francisco.jordano)
status-b2g-v1.2: --- → fixed

Updated

4 years ago
Whiteboard: [c= p=4 s= u=1.2] → [c= p= s= u=1.2]
You need to log in before you can comment on or make changes to this bug.