Closed Bug 924934 Opened 11 years ago Closed 10 years ago

Mixed Content Blocking shield icon is not displayed on some devices

Categories

(Firefox for Android Graveyard :: General, defect, P5)

27 Branch
All
Android
defect

Tracking

(firefox27 affected, firefox28 affected, firefox29 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected, fennec+)

RESOLVED INVALID
Tracking Status
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected
fennec + ---

People

(Reporter: u421692, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Environment:
Device: Samsung Galaxy R
Build: Nightly 27.0a1(2013-10-09)

Steps to reproduce:
1. Open https://people.mozilla.org/~bsterne/tests/62178/test.html

Expected result:
Page is loaded with the shield icon displayed in the URL bar

Actual result:
Page is loaded but the shield icon is not displayed in the URL bar, making Mixed Content Blocking feature unusable.

Note: I was able to reproduce this issue only on this particular device, and this particular web page. On "mail.yahoo.com" the icon is displayed.
The error I see in logcat:

10-09 17:58:01.070: E/GeckoConsole(2068): [JavaScript Error: "Error: Permission denied to access property 'log'" {file: "https://people.mozilla.org/~bsterne/tests/62178/static/content/iframe.html" line: 24}]
When you load the page the first time, do you see the green secure <iframe> and the green text that the insecure script did not load? Also, is this a new profile?
The <iframe> and the green text are loaded, and reproduces even with clean or populated profile.
Is this a regression?
Flags: needinfo?(mihai.g.pop)
Tested on several Firefox builds, and can not reproduce this issue anymore. Closing as WFM for now.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: needinfo?(mihai.g.pop)
Resolution: --- → WORKSFORME
I can reproduce this using the above steps on:
Device: LG Optimus 4X (Android 4.1.2)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Mixed Content Blocking shield icon is not displayed on Samsung Galaxy R → Mixed Content Blocking shield icon is not displayed on some devices
Status: REOPENED → NEW
tracking-fennec: --- → ?
MCB has shipped a couple of releases back, is this a recent regression or has this always existed ?
Flags: needinfo?(aaron.train)
This has been around since initial implementation.
Flags: needinfo?(aaron.train)
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → +
(In reply to Aaron Train [:aaronmt] from comment #7)
> This has been around since initial implementation.

Given this, not tracking but will consider a low risk uplift.
Shield is not displayed. Mozilla Firefox for Ubuntu canonical - 1.0 27.0.1 Ubuntu 13.10. This makes some features of our main teaching website inaccessible to users.
This is an Android bug.
In other words hhardy you should check that the behavior is reproducible with Firefox from Mozilla http://www.mozilla.org/en-US/firefox/all/ then file a bug with Mozilla or Ubuntu as appropriate.
filter on [mass-p5]
Priority: -- → P5
If this bug is reproducible on Ubuntu, it sounds like a core issue, not a Firefox for Android issue.

Monica, have you seen reports like this before? Maybe something else has fixed this by now?
Assignee: margaret.leibovic → nobody
Flags: needinfo?(mmc)
Tanvi would probably know more.
Flags: needinfo?(tanvi)
Flags: needinfo?(mmc)
Using Firefox 33 and 35.01a on Ubuntu 12.04, I go to https://people.mozilla.org/~bsterne/tests/62178/test.html.  I see the shield icon and the green lock and the green content on the page.  I can disable protection, the green lock turns into a yellow warning triangle and the green content turns red.  Webconsole messages look like they should too.

The Mixed Content Blocker seems to be working as expected.  Maybe this is only an issue on Ubuntu 13.10?  QA, can you help verify the issue?  Mihai, are you still the right person to help with Mixed Content issues?
Flags: needinfo?(tanvi) → needinfo?(mihai.morar)
Keywords: qawanted
This was filed as an issue across some devices, we can check in with Mihai Pop to retest against trunk.
Flags: needinfo?(mihai.g.pop)
Keywords: qawanted
I couldn't reproduce this issue anymore, on any devices, or any firefox branches.
I think that it might be a human error, when opening a short link that has the address with http and not https.
Closing this as invalid.
Status: NEW → RESOLVED
Closed: 11 years ago10 years ago
Flags: needinfo?(mihai.g.pop)
Resolution: --- → INVALID
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.