Add 'suggestions' tool giving tips for improving page's performance, accessibility, code structure etc.

RESOLVED DUPLICATE of bug 1415357

Status

--
enhancement
RESOLVED DUPLICATE of bug 1415357
5 years ago
4 months ago

People

(Reporter: glind, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I find the Chrome devtools advice about how to structure code helpful.  Our devtools could give advice (summarized across all tabs) that might help improve the "Firefox as Web IDE" story.
(In reply to Gregg Lind (User Advocacy - Heartbeat - Test Pilot) from comment #0)
> I find the Chrome devtools advice about how to structure code helpful.

Where can this advice be found? And what info does it contain exactly?

Sebastian
Flags: needinfo?(glind)
Hardware: x86 → All
Gregg, I still couldn't find the feature you mentioned. And I am wondering how this 'suggestions' tool should work.

Sebastian
As I didn't get any feedback so far and the feature description is very vague, I close this bug now.

Note that MDN is planning to integrate more into the DevTools, which is somewhat related, I guess. But again, I never saw this "advice about how to structure code" within the Chrome DevTools, so I'm unsure what it does exactly.

Sebastian
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(glind)
Resolution: --- → INVALID
Created attachment 8752264 [details]
Screen Shot 2016-05-13 at 11.54.30 AM.png

Screenshot showing CHROME DEVTOOLS AUDITS pane, with advice for developers about specific page issues.
Sorry for the late answer.  See attached screen shot.  Under dev tools > audits, it suggests things are likely (for some opinion of likely) to be problem areas.  Even if the answers are cargo cult-ish, it gives the illusion of 'something to do', and user benefit.
Ah, now I see what you mean. It's something like YSlow[1] and Page Speed[2] for Firebug.
This is indeed something very desirable. The Firebug Working Group previously discussed to implement something like this in upcoming Firebug versions. Therefore I'm CC'ing Honza.

I could imagine this tool to include even more features than only performance analysis. It could also provide accessibility advices (like FireEyes[3] and AInspector) and tips for tightening up your code (like CSS Usage[5]).

Sebastian

[1] https://getfirebug.com/wiki/index.php/Firebug_Extensions#YSlow
[2] https://getfirebug.com/wiki/index.php/Firebug_Extensions#Page_Speed
[3] https://getfirebug.com/wiki/index.php/Firebug_Extensions#FireEyes
[4] https://addons.mozilla.org/de/firefox/addon/accessibility-inspector-for/
[5] https://getfirebug.com/wiki/index.php/Firebug_Extensions#CSS_Usage
No longer blocks: 925060
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: add 'suggestions' tools to summarize advice → Add 'suggestions' tool giving tips for improving page's performance, accessibility, code structure etc.
Regarding accessibility, I saw right now there is already a very nice and very well integrated extension for the DevTools called aXe Developer Tools:

https://addons.mozilla.org/firefox/addon/axe-devtools/

Sebastian
Bug 1415357 was recently filed by the DevTools team covering the same feature and acting like a meta-issue. In the hope that that bug gets more traction, I mark this one as a duplicate of it.

Sebastian
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1415357

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.