MakeAPI isn't setting updatedAt attribute when creating a new make

RESOLVED FIXED

Status

Webmaker
MakeAPI
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jbuck, Assigned: cade)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Currently the MakeAPI isn't setting the updatedAt attribute when creating a new make. The offending line of code is https://github.com/mozilla/MakeAPI/blob/master/routes/make.js#L55-L60 . We'll also need to write a migration script that sets the updatedAt attribute if it doesn't exist.
(Reporter)

Updated

4 years ago
Blocks: 924528
(Reporter)

Updated

4 years ago
Attachment #815033 - Flags: review?(jon) → review+

Comment 2

4 years ago
Commit pushed to master at https://github.com/mozilla/MakeAPI

https://github.com/mozilla/MakeAPI/commit/ca3a10ac41bb06f0a2a78117c52d6a9c74d3b477
Fix Bug 925048 - set updatedAt on creation, add migration to update makes with a null updatedAt (set to createdAt)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
(Reporter)

Comment 3

4 years ago
We needed to run a manual ES sync after running the migration script to have the updated sorting work properly.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 894083
(Reporter)

Updated

4 years ago
Duplicate of this bug: 927487
You need to log in before you can comment on or make changes to this bug.