Closed Bug 925050 Opened 6 years ago Closed 6 years ago

browser_toolbox_window_shortcuts.js times out when a tool in defaultTools is disabled by default

Categories

(Firefox :: Untriaged, defect)

25 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 27

People

(Reporter: rjacob, Assigned: rjacob)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131001024718

Steps to reproduce:

After making a change which adds a new, disabled-by-default devtools panel, browser_toolbox_window_shortcuts times out.


Actual results:

The test tries to synthesize the shortcut key for the disabled panel. Since the panel is disabled, it's never selected, and the toolbox-select event the test is expecting never gets fired.


Expected results:

The test should enable all disabled tools at the beginning of the test and disable them at the end of the test.
Blocks: 907451
Attached patch PatchSplinter Review
Enables all default-disabled tools at the start of the test and disables them afterward.
Attachment #815057 - Flags: review?(nfitzgerald)
Comment on attachment 815057 [details] [diff] [review]
Patch

Review of attachment 815057 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #815057 - Flags: review?(nfitzgerald) → review+
Whiteboard: [checkin-needed]
https://hg.mozilla.org/integration/fx-team/rev/e18f53aabaac

FYI, there's a checkin-needed bug keyword too, so you don't need to muck with the whiteboard :)
Assignee: nobody → rjacob
Flags: in-testsuite+
Whiteboard: [checkin-needed] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e18f53aabaac
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.