[B2G][Music] The user cannot long tap a song under the "Songs" tab to share it

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: squib)

Tracking

unspecified
1.3 Sprint 3 - 10/25
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: burirun2)

Attachments

(1 attachment)

Created attachment 815043 [details]
MusicShare.mp4

Description:
The user cannot long tap a song under the "Songs" tab to share it. They can long press the song under the "Artists and Albums" tabs to share it.

Repro Steps:
1)  Updated Buri to Build ID: 20131009004001
2)  Tap on the "Music" icon.
3)  Tap on the "Music Note" icon to see all the songs that are on the phone.
4)  Long tap on a song.

Actual:
The share menu is not prompted to the user when they long press on a song under the "Songs" tab.

Expected:
The share menu is prompted to the user when they long press on a song under the "Songs" tab.

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131009004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/e5edb484e2a9
Gaia: 672c47bf94b69a329e0aacb9228a6aa16ade6226
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
See attached: video clip
Please note that the functionality is different on Leo v 1.1.0

Environmental Variables
Device: Leo v 1.1.0 Mozilla COM RIL
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240 

When a user long presses on a song on 1.1, the user is prompted if they want to pair a Bluetooth device.

Updated

4 years ago
blocking-b2g: --- → koi?
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
Duplicate of this bug: 925094

Updated

4 years ago
QA Contact: nkot

Comment 3

4 years ago
this is not a regression, there was no option to share music from the Songs tab 

v1.1 builds 
- the user is able to share music files over BT by longpress the song in Artists or Albums tab

v1.2 builds 
- there are additional options to share files via Email and MMS, again, by lonpress the song in Artists and Albums tabs

- longpress the song in the Songs tab will do nothing either on v1.1 or v1.2 

Buri v1.1
Gaia   e5adcf3c23b6709a51087539bc4cdb67683ca4a0
SourceStamp c630289d6388
BuildID 20131004041201
Version 18.0

Buri v1.2
Gaia   672c47bf94b69a329e0aacb9228a6aa16ade6226
SourceStamp e5edb484e2a9
BuildID 20131009004001
Version 26.0a2
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: koi? → ---

Updated

4 years ago
blocking-b2g: --- → koi+
(Assignee)

Comment 4

4 years ago
Taking this.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Jim,

Please note that we just landed a koi+ patch (bug 830040) with a real share button in the now playing view.

And as part of that, Mahsa removed the contextmenu event handler for the long-press to share.

I'd suggest that we WONTFIX this bug and just rely on the real share button.  The undiscoverable long press thing was always a hack, and I suspect we should let it die.

Unless we've got UX telling us that we've got to add this back in, I think we should WONTFIX
(Assignee)

Comment 6

4 years ago
Agreed, let's WONTFIX this. If UX wants this, feel free to reopen, but then we'll probably want to add the contextmenu handler back in for the other views.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Target Milestone: --- → 1.3 Sprint 3 - 10/25
You need to log in before you can comment on or make changes to this bug.