[B2G][Contacts] Contact names with accented characters are not exported correctly to a VCard

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: KTucker, Assigned: mai)

Tracking

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: burirun2)

Attachments

(3 attachments)

Created attachment 815129 [details]
Vcard.png

Description:
After exporting a contact name that has accented characters, the name will not appear correctly on the VCard.

Repro Steps:
1)  Updated Buri to Build ID: 20131009004001
2)  Create a contact that contains accented characters such as ÀÈÌÒÙ
3)  Tap the "Settings" icon in contacts.
4)  Tap on "Export Contacts".
5)  Tap on "Memory card".
6)  Select the contact that was created with accented characters.
7)  Tap on "Export".
8)  After the contact has been exported, exit contacts and tap on the "Settings" icon.
9)  Tap on "Enable USB storage".
10) Plug the phone via USB into the computer.
11) Search for the Vcard that was created in the files on the SD card and open it.

Actual:
The contact with accented characters that is exported to the memory card, do not appear correctly on the VCard created.

Expected:
The contact name on the VCard matches the contact name exported from the phone.

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131009004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/e5edb484e2a9
Gaia: 672c47bf94b69a329e0aacb9228a6aa16ade6226
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9786/
See attached: screenshots
This issue does not reproduces on Leo v1.1.1 Mozilla Rill because the functionality to export contacts did not exist.

Environmental Variables
Device: Leo v 1.1.0 Mozilla COM RIL
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240

Updated

5 years ago
blocking-b2g: --- → koi?

Updated

5 years ago
Assignee: nobody → mri
David

Please review.
Flags: needinfo?(dscravaglieri)
triage: koi+, impact release markets where accented letters are used
blocking-b2g: koi? → koi+
clear ni?, bug is a blocker
Flags: needinfo?(dscravaglieri)
Target Milestone: --- → 1.2 C3(Oct25)
(Assignee)

Comment 5

5 years ago
Hi,
the charset of the vcard is utf-8. Your operating system might not being displaying these accented characters, because you might have a different encoding. Before importing your vcard file, you migth have to transform the file encoding.

Below i give you an example that may help you doing it. 

STR to configure outlook to use UTF-8 for import vcard files.
1 Select "Options" on your File menu.
2. Click the "Advanced" heading on the left side of the window and then scroll to the "International Options" heading near the bottom.
3.Place a check in the box labeled "Automatically select encoding for outgoing vCards" and click "Unicode (UTF-8)" on the drop-down menu.
4. Click "OK."

Regards.
(Assignee)

Updated

5 years ago
Flags: needinfo?(ktucker)
QA Wanted to address comment 5
Keywords: qawanted
We do not have the actual Outlook program here at the office. We can only use Outlook.com. I have attached a new screenshot of the actual VCARD that was created on the SD card after exporting the contact from the phone. You can see from the screenshot that all the accented characters are seen as underscores. This appears to be an export issue. The original name with the accented characters can be seen in my original screenshot that i attached to this issue.
Flags: needinfo?(ktucker)
Created attachment 815918 [details]
New screenshot of the actual VCARD created on the SD card after export
(Assignee)

Comment 9

5 years ago
Created attachment 816064 [details]
VCARD in outlook, notepad and windows contacts

My operating system is windows 7. As you can see on the screenshot, I can not import my vcard well-encoding with windows contacts, meanwhile the accented characters are well displayed when i open my vcard in notepad or outlook applications (outlook is configured as related in comment #5).
Could you probe to open your vcard with the notepad application and check if the accented characters are displayed correctly?
Flags: needinfo?(ktucker)

Updated

5 years ago
QA Contact: nkot

Comment 10

5 years ago
In response to comment 9,

Contacts with accented characters are displayed correctly when opened with Notepad++ (on Windows) or with Text Editor (on Linux).
Flags: needinfo?(ktucker)
Keywords: qawanted
Sounds like this is works for me then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.