Closed Bug 925298 Opened 6 years ago Closed 6 years ago

WebGL out of memory

Categories

(Core :: Canvas: WebGL, defect)

25 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 902922

People

(Reporter: gulp.twins96, Unassigned)

Details

(Whiteboard: [MemShrink:P2])

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131007213254

Steps to reproduce:

Trying to develop WebGL UI with the three.js library loading 3d models in js, obj, bin format


Actual results:

On reload the page the browser double the used RAM until it crashes out of memory


Expected results:

Why the memory double ?
With other browsers this doesn't happens...
URL of the WebGL demo maybe? Without testcase, it's hard to test and debug.
Flags: needinfo?(gulp.twins96)
This is one of the base examples on the main page of the three.js library:
http://threejs.org/examples/#webgl_geometry_terrain_raycast
After a couple of reloads the memory used becomes very huge and next time you refresh the page the browser crashes ...
(I've tested also with Chrome but this doesn't happens ...)
Flags: needinfo?(gulp.twins96)
Could you make another test please.

Create a new testing profile (see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) and open the page about:memory. Then load this demo and try to reproduce the memory crash.
When you see the browser is becoming unresponsive, switch to about:memory and save a memory report (button "measure and save").

In addition, if you're able to reproduce the Firefox crash, open about:crashes and paste a crash link (bp-...).
Component: Untriaged → Canvas: WebGL
Flags: needinfo?(gulp.twins96)
Product: Firefox → Core
Whiteboard: [MemShrink]
Version: unspecified → 25 Branch
First memory report.
This is the clean profile with no web pages opened
Flags: needinfo?(gulp.twins96)
2nd attachment, this is after the 3d model loads 1st time
Memory report after 1st reload
Memory report after 2nd reload.
After this the browser become unstable ...
Windows aren't being cleaned up...

576.63 MB (100.0%) -- explicit
├──433.11 MB (75.11%) -- window-objects
│  ├──253.19 MB (43.91%) -- top(none)/detached/window(http://threejs.org/examples/webgl_geometry_terrain_raycast.html)
│  │  ├──253.18 MB (43.91%) -- js-compartment(http://threejs.org/examples/webgl_geometry_terrain_raycast.html,
Whiteboard: [MemShrink] → [MemShrink:P2]
> │  ├──253.19 MB (43.91%) --
> top(none)/detached/window(http://threejs.org/examples/
> webgl_geometry_terrain_raycast.html)

Specifically, the presence of a detached window suggest that the entire window has somehow been leaked.
Note that this happens also without a detached window, like:
http://threejs.org/examples/webgl_geometry_terrain_raycast.html
Thanks for the report.  This sounds like a dupe of bug 902922.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 902922
Thank you for your help,
maybe it is very similar, but note that I do not load textures and it happens anyway.
I do not understand if that bug is going to be solved soon...or later ... (?)
> I do not understand if that bug is going to be solved soon...or later ... (?)

It should be fixed fairly soon.  Patches have already been written (they got posted in spin-off bug 927705) and they're just waiting to be reviewed.  With luck, they'll land by the end of the week.
Wow, that sounds great, does this means the patch will be a part of the next firefox official release ? Or just in alpha or beta ?
I'm testing both with alpha 27 and beta 26...

Thank you !
If it lands soon it'll be in version 27, which is currently the "Nightly" channel.  (Version 26 is on the "Aurora" channel, version 25 is currently on the "Beta" chanenl, version 24 is the current official release.)  It might be considered for backporting to version 26, too.
You need to log in before you can comment on or make changes to this bug.