OSX latest tinderbox/nightly: "[NSEvent phase]: unrecognized selector sent to instance 0xXXXXXXXX" when trying to use mouse scroll wheel.

RESOLVED DUPLICATE of bug 925411

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 925411
4 years ago
4 years ago

People

(Reporter: sci-fi, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131010030202

Steps to reproduce:

Trying to vertically scroll any (long) page in latest Nightly/tinderbox with mouse scroll wheel.


Actual results:

Produces lots of these pairs of messages to console/stdout:

> 2013-10-10 06:32:25.957 firefox[74766:a07] -[NSEvent phase]: unrecognized selector sent to instance 0x54c89800
> 2013-10-10 06:32:25.958 firefox[74766:a07] Mozilla has caught an Obj-C exception [NSInvalidArgumentException: -[NSEvent phase]: unrecognized selector sent to instance 0x54c89800]



Expected results:

We ought to be able to scroll long pages with mouse scroll wheel.  The wheel does work in other apps, just not in latest Nightly/tinderbox builds.
(Reporter)

Comment 1

4 years ago
I fetched this m-c tinderbox build to steer clear of the recent changes to OSX code:

> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131009123207 CSet: a141e39bf6da

The mouse scroll wheel works now, without the error messages.  ;)

BTW the Thunderbird latest Daily/tinderbox is affected with this same bug.  For it I fetched the earlier c-c tinderbox build:

> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:27.0) Gecko/20100101 Thunderbird/27.0a1 ID:20131009030201 CSet: 01c56e89552c

… again to steer clear of the recent changes in its m-c section, and again the mouse scroll wheel once again works.

I think the recent OSX code changes have produced this fluke.  ;)

FWIW,
MacOSX 10.6.8 fully updated.
Running Nightly & Daily in 32-bit mode (to match EFI/BIOS status [this is a model "iMac6,1" needing 32-bit kernel mode], even tho 64-bit app mode is supported [CPU is Core-2-Duo]).
Mouse is Logitech TrackMan Wheel, P/N 804360-1000.  No special drivers are loaded for this critter, I'm using OSX's regular generic mouse support.
(Reporter)

Updated

4 years ago
Version: 27 Branch → Trunk
Thanks for reporting this bug.

A quick mxr search shows that -[NSEvent phase] is called only twice, here and then several lines down: http://hg.mozilla.org/mozilla-central/annotate/500765bd8dd9/widget/cocoa/nsChildView.mm#l4123

-[NSEvent phase] was added in 10.7 [1], so if you're on 10.6 that explains why you're seeing those errors.

Bug 917761 added both of those calls, so noting the dependency.

[1] https://developer.apple.com/library/mac/documentation/Cocoa/Reference/ApplicationKit/Classes/NSEvent_Class/Reference/Reference.html#//apple_ref/occ/instm/NSEvent/phase
Blocks: 917761
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
(In reply to Drew Willcoxon :adw from comment #2)
> A quick mxr search shows that -[NSEvent phase] is called only twice, here
> and then several lines down:
> http://hg.mozilla.org/mozilla-central/annotate/500765bd8dd9/widget/cocoa/
> nsChildView.mm#l4123
> 
> -[NSEvent phase] was added in 10.7 [1], so if you're on 10.6 that explains
> why you're seeing those errors.
> 
> Bug 917761 added both of those calls, so noting the dependency.

The problematic [NSEvent phase] call was introduced by bug 868648. The bug here is a duplicate of bug 925411. Note that the calls in bug 917761 were placed behind nsCocoaFeatures::OnLionOrLater checks, so those didn't cause this issue.

Closing this as duplicate of bug 925411. Please let me know if I missed something.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925411
Blocks: 868648
No longer blocks: 917761
(Reporter)

Comment 4

4 years ago
Hi,

Thanks everyone for the explanations.

(In reply to Stephen Pohl [:spohl] from comment #3)
> Closing this as duplicate of bug 925411. Please let me know if I missed something.
> 
> *** This bug has been marked as a duplicate of bug 925411 ***

I swear I tried searching on the error messages shown in this bug, and nothing showed up.

So I thought no one has seen this bug, and I should report it ASAP.

I didn't report this to the nightly mail-list due to latest Thunderbird builds are (still) broke for other reasons.  I know I could simply go to an earlier build for it, but as of this writing the server has wiped earlier builds out (way too short a clean-up timeout there IMO).  Then of course there's the official release builds.  ;)

But a note of good news: starting with the later nightly/tinderbox builds on Friday (Oct.11) the mouse scroll wheel does work once again here.  (I am just-now able to report this, too, to explain this lateness.)  ;)

(I know I could upgrade to 10.7 on this hardware, but 10.6 still has Rosetta and does not depend on cloudy situations <hint-hint>.  I _am_ already planning on moving to full F/OSS tho, it's just taking much longer than expected [what with the political situations and my health etc.] so I expect to stay on 10.6 'til then.)

Thanks again.
You need to log in before you can comment on or make changes to this bug.