Closed Bug 925331 Opened 7 years ago Closed 7 years ago

Cannot enter PIN code after you dismiss keyboard

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 verified)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- verified

People

(Reporter: rik, Assigned: mai)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1) Go to Enter PIN Code screen
2) Tap the content to dismiss the keyboard
3) Tap the input field

Expected:
Keyboard shows up to enter PIN Code

Actual:
Nothing
Summary: Cannot enter PIN code if you left the → Cannot enter PIN code after you dismiss keyboard
QA Contact: sparsons
Hi Anthony,

Could you please provide the build and device information you were using at the time you found this issue? 

Thanks!
Flags: needinfo?(anthony)
This has been happening for a while (bug 88719 solved a part of it, and that one is from june'13), so probably any build that you can choose
Really, not my day with typos :( I meant bug 887190
Depends on: 887190
This issue first reproduces back to the first Buri 1.2 Build BuildID 20130621031231

Gaia   e2f19420fa6a26c4287588701efaec09a750dba1
SourceStamp 7ba8c86f1a56
BuildID 20130621031231
Version 24.0a1

Last working was the Buri 6/20 1.1 BuildID 20130620070209

Gaia   c507ff65b51194383da65f8927164f078a3e1f79
SourceStamp 3e144cc723d3
BuildID 20130620070209
Version 18.0
Duplicate of this bug: 926775
Assignee: nobody → mri
Attached file patch v1
Please, could you review my code?
Attachment #816971 - Flags: review?(fernando.campo)
Comment on attachment 816971 [details]
patch v1

This looks like a workaround, not the real fix.
Flags: needinfo?(anthony)
Comment on attachment 816971 [details]
patch v1

Cool, quick and easy :)

Thanks!

merged on master 7674c5083645d9566def26cb35fe4e10dd9b5903
Attachment #816971 - Flags: review?(fernando.campo) → review+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Sorry for the comment, I think I read an earlier version of the pull request.
No need to be sorry Rik ;) totally my fault for not commenting that marina updated the pull request after your comment. Now when I read the thread again, seems like I'm ignoring you and r+ing directly. Not my intention, sorry for that!
Blocks: 929520
Duplicate of this bug: 929520
No longer blocks: 929520
koi+ since it is a regression issue.
blocking-b2g: koi? → koi+
This must be uplifted to version 1.2 branch, added status flag as affected
Uplifted 7674c5083645d9566def26cb35fe4e10dd9b5903 to:
v1.2: 2010dd117f5973e955bbb7fea76806ee6fcec1a2
Verified in branch 1.2

Device: Unagi
Gecko-0770a5a
Gaia-cb981e2
Status: RESOLVED → VERIFIED
Changing tracking flag to verified based on comment 15.
Sorry about that, I misread the comment 15. I just verified this issue as fixed on Buri 1.2.

Environmental Variables:
Device: Buri v1.2 comRIL
BuildID: 20131111004004
Gaia: 670b2c8329bca6f142939185be71274166d82bb8
Gecko: 1ac147e4e2f0
Version: 26.0
You need to log in before you can comment on or make changes to this bug.