"Remove All Sites" button is active even when there are no sites

VERIFIED FIXED

Status

()

VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The same problem as in bug 92386. This just for the Form Manager.

I you dont have any sites in the Forms Never Previed and Forms Never Saved tab 
in the Form Manager the "Remove All Sites" button is still active. This makes no 
sense to a user.

build 20010725

Comment 1

18 years ago
Created attachment 43785 [details] [diff] [review]
adding null check to make this work

Comment 2

18 years ago
cc'ing blake and vishy for reviews.

Note that although this bug (for forms) sounds similar to bug 92386 (for 
cookies), the cause is completely different.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4
r=vishy

Comment 4

18 years ago
sr=blake

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
Fix checked in.

Comment 6

18 years ago
Verified fixed linux build 2001-09-13-05-0.9.4
Verified fixed mac build 2001-09-13-03-0.9.4
Verified fixed w2k build 2001-09-13-05-0.9.4
Status: RESOLVED → VERIFIED
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
Target Milestone: mozilla0.9.4 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.