If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Impossible to use or remove bookmarks added in v1.2 or before

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nical, Assigned: julienw)

Tracking

({dataloss, regression})

unspecified
ARM
Gonk (Firefox OS)
dataloss, regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

Attachments

(1 attachment)

25.20 KB, patch
crdlc
: review+
Carmen Jimenez Cabezas
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
I added a few sites to the home screen with everything.me and then updated my keon device to master by flashing a nightly build provided on the geeksphone website.

I can't launch sites anymore since I updated (the icon turns blue-ish when I press it as expected, but nothing happens beyond that).

I also can't remove them from the home screen anymore: the (x) button is there but nothing happens when I press it.
I can only move the icons around in the home screen.

All other sites/apps that I added after flashing the build work normally, I can use and uninstall them.
(Assignee)

Comment 1

4 years ago
qawanted for the STR:
* have a phone on 1.1
* add a shortcut to a webpage from the browser on homescreen
* add a shortcut to a e.me page on homescreen
* upgrade to 1.2
* try to launch these shortcuts

I'd like to test the migration path from 1.1 to 1.2 here.

If this works, then try to upgrade to 1.3 and do the same.

Please do the same between 1.0 and 1.1 too.
Keywords: qawanted
(Assignee)

Comment 2

4 years ago
At the end of the STR, please add:
* try to remove the shortcuts (longpress + tap on red cross)
OTA Update testing is blocked, so we can't address the testing request here.
Actually re-reading the bug - the QA Wanted request is completely unrelated to the bug. This is a geeksphone specific bug, unrelated to the OTA update workflow.
Keywords: qawanted
(Assignee)

Comment 5

4 years ago
I want to test going from a version to another, on any phone. I don't see why this would be a geeksphone specific bug, as the faulty behaviour lies entirely in the Homescreen app.

If you can't test using OTA, then please test with manually flashing images without flashing the data.
Keywords: qawanted
(In reply to Julien Wajsberg [:julienw] from comment #5)
> I want to test going from a version to another, on any phone. I don't see
> why this would be a geeksphone specific bug, as the faulty behaviour lies
> entirely in the Homescreen app.

Because it's involved in the flashing process with geeksphone builds. We don't do investigations for those bugs. And wanting something tested doesn't you flag a random bug for the request - email qa-b2g@mozilla.org about this.

> 
> If you can't test using OTA, then please test with manually flashing images
> without flashing the data.

We don't do testing in this workflow - it's not user visible.
Keywords: qawanted
(Assignee)

Comment 7

4 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Julien Wajsberg [:julienw] from comment #5)
> > I want to test going from a version to another, on any phone. I don't see
> > why this would be a geeksphone specific bug, as the faulty behaviour lies
> > entirely in the Homescreen app.
> 
> Because it's involved in the flashing process with geeksphone builds. We
> don't do investigations for those bugs. 

The way the flashing is done has nothing to do with the issue here.

> And wanting something tested doesn't
> you flag a random bug for the request - email qa-b2g@mozilla.org about this.

I don't understand this sentence.

> 
> > 
> > If you can't test using OTA, then please test with manually flashing images
> > without flashing the data.
> 
> We don't do testing in this workflow - it's not user visible.

Sorry, I really don't follow you. The _same_ _migration_ _code_ will be executed.

I'll do the investigation myself then. I won't write all the bad things I'm thinking right now.
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #7)
> 
> > And wanting something tested doesn't
> > you flag a random bug for the request - email qa-b2g@mozilla.org about this.
> 
> I don't understand this sentence.

Meant to say - if you want something misc investigated, email qa-b2g@mozilla.org.
(Assignee)

Comment 9

4 years ago
I found a migration problem, filed bug 933752. Not sure this is the root cause though, but it could be.
Flags: needinfo?(felash)
(Assignee)

Comment 10

4 years ago
So bug 933752 was not the reason.

The reason was bug 910316 which makes it a regression. I'll also add the dataloss key, as existing bookmarks can not be used at all.

Fortunately, bug 910316 has not landed in 1.2, this was a wise decision ;) Therefore this is for 1.3 only.

A patch is coming.
Assignee: nobody → felash
Blocks: 910316
blocking-b2g: --- → 1.3?
Keywords: dataloss, regression
Summary: Impossible to use or remove apps that were added through everything.me before updating from 1.0 to master → Impossible to use or remove bookmarks added in v1.2 or before
(Assignee)

Comment 11

4 years ago
STR:
* have a phone on 1.2
* add a bookmark from the browser or e.me
* update the phone to 1.3
* try to launch the bookmark
(Assignee)

Comment 12

4 years ago
Created attachment 8337530 [details] [diff] [review]
patch v1

Github pull request is https://github.com/mozilla-b2g/gaia/pull/13992


* handle correctly old-style bookmarks
* did better part of the tests
---
 apps/homescreen/js/grid.js                        |    5 +
 apps/homescreen/test/unit/grid_test.js            |  310 ++++++++++++++++-----
 apps/homescreen/test/unit/mock_bookmark.js        |   22 ++
 apps/homescreen/test/unit/mock_grid_components.js |    6 +-
 apps/homescreen/test/unit/mock_home_state.js      |  155 +----------
 apps/homescreen/test/unit/mocks_helper.js         |   58 ----
 apps/homescreen/test/unit/setup.js                |    2 +-
 7 files changed, 282 insertions(+), 276 deletions(-)
 create mode 100644 apps/homescreen/test/unit/mock_bookmark.js
 delete mode 100644 apps/homescreen/test/unit/mocks_helper.js
Attachment #8337530 - Flags: review?(crdlc)
Comment on attachment 8337530 [details] [diff] [review]
patch v1

Excellent work as usual!! Simple solution, thanks a lot Julien! Moving the review of the tests to Carmen because she implemented them and I pretty sure that she knows more than me there
Attachment #8337530 - Flags: review?(crdlc)
Attachment #8337530 - Flags: review?(cjc)
Attachment #8337530 - Flags: review+
Status: NEW → ASSIGNED

Updated

4 years ago
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8337530 [details] [diff] [review]
patch v1

Review of attachment 8337530 [details] [diff] [review]:
-----------------------------------------------------------------

The tests look great, thanks for cleanning them up.
Attachment #8337530 - Flags: review?(cjc) → review+
(Assignee)

Comment 15

4 years ago
Thanks all!

master: 43a0d5ad2bcb258bffc46b95eb2850ba3d171074
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.