Closed Bug 925520 Opened 6 years ago Closed 6 years ago

Default support contacts fail to render call support contacts specified in the default customization

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: jsmith, Assigned: aus)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

Build: Master 10/10/2013 Buri

STR

1. Follow https://wiki.mozilla.org/B2G/QA/Customizations#Build_Setup to setup your build with no SIM included
2. Go to Settings --> Help

Expected

Online support & call support information should be included.

Actual

Only online support information is included.

Test support.json is here - https://github.com/mozilla/qa-testcase-data/blob/gh-pages/customization/reference/support.json.
blocking-b2g: --- → koi?
Whiteboard: [systemsfe]
Blocks: 891724
Keywords: regression
Whiteboard: [systemsfe] → [systemsfe][koi+]
I'll look into this today.
Assignee: nobody → aus
Status: NEW → ASSIGNED
blocking-b2g: koi? → koi+
Whiteboard: [systemsfe][koi+] → [systemsfe]
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Runtime Support Contacts Customization
[User impact] if declined: Call Info from build time json file won't show in help panel in Settings Application.
[Testing completed]: FxOS Simulator, B2G Desktop, GP Peak.
[Risk to taking this patch] (and alternatives if risky): Negligible 
[String changes made]: None.
Attachment #817346 - Flags: review?(kyle)
Attachment #817346 - Flags: approval-gaia-v1.2?(anygregor)
Attachment #817346 - Flags: review?(kyle) → review+
Attachment #817346 - Attachment mime type: text/plain → text/html
Comment on attachment 817346 [details]
Patch - v1 - Fixed undesired closure, handle error case.

This already has koi+ - no need to ask for approval.
Attachment #817346 - Flags: approval-gaia-v1.2?(anygregor)
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Verified on the latest pull of master with test repository - I'm seeing call support data populating correctly.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Uplifted 4a704d649f010de7c4de69f9fed58856bacb1fd0 to:
v1.2: 93acbc4c59b574401be42eee374c3839ff7275e5
You need to log in before you can comment on or make changes to this bug.