[B2G][Contacts] A separate contact entry is not created when the user imports a matching contact that has a different phone number from hotmail

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2)

Attachments

(1 attachment)

Created attachment 815598 [details]
Outlookreplacecontactbug.txt

Description:
Another separate contact is not created when importing a contact from Outlook with the same information as a saved one on the SD card but the contacts have different phone numbers.

Repro Steps:
1)  Updated Buri to Build ID: 20131010004001
2)  Create a contact on hotmail that has a first name, last name, phone number and an email address.
3)  Create a contact on the phone with a first name, last name, phone number and email address. Make all the information exactly the same as the one created in hotmail except make the phone number completely different.
4)  After creating the contact, tap on the "Settings" icon in contacts.
5)  Tap on "Import Contacts".
6)  Tap on the "Outlook" button and sign in with a hotmail account.
7)  Select the contact that matches the one saved on the phone and tap on "Import".
8)  After importing the contact, look at the contact list.

Actual:
Notice that a separate contact wasn't created. The phone number of the contact that was saved on the phone replaces the phone number of the matching contact imported from hotmail.

Expected:
The hotmail imported contact is created on the phone as a separate entry since the phone number is different than the contact saved on the phone.

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131010004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
Gaia: 51f3c79ea93bb91d3b12e50b49d203a049a94a9b
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/10302/
See attached: logcat
This issue does not reproduce on Leo v 1.1.0 Mozilla Com Rill

Environmental Variables
Device: Leo v 1.1.0 Mozilla COM RIL
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240

A separate contact entry is created when the matching contact imported from hotmail has a different phone number.
The hotmail contact had the phone number in the "other" field and not the mobile field. So when i imported the hotmail contact it merged the contacts. I thought i was seeing a bug but after changing the phone number on hotmail from "Other" to "Mobile", the functionality worked properly. A separate contact was made so I'm closing this issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Keywords: regression, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.