Fail to link xul.dll on VS2013 RC - Mixing of MT with MD libs in nsBidiUtils .obj

RESOLVED DUPLICATE of bug 926083

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 926083
4 years ago
4 years ago

People

(Reporter: Xavier Fung, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
There are the errors:

115:51.26 uachelper.obj : error LNK2038: mismatch detected for 'RuntimeLibrary':
 value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsBidiUtils
.obj
115:51.26
115:51.26 readstrings.obj : error LNK2038: mismatch detected for 'RuntimeLibrary
': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsBidiUti
ls.obj
115:51.26
115:51.27 updatelogging.obj : error LNK2038: mismatch detected for 'RuntimeLibra
ry': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsBidiU
tils.obj

It seems this is similar to Bug 732124.
Hope you don't mind that I forward-dupe your bug to mine (I did not find yours when I filed mine), as I've done some analysis what checkin actually triggered (probably not caused) this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926083
You need to log in before you can comment on or make changes to this bug.