There are no means provided with which I can disable HiDPI.

RESOLVED DUPLICATE of bug 851268

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 851268
5 years ago
5 years ago

People

(Reporter: shaman.wulf, Unassigned)

Tracking

({access})

24 Branch
x86_64
Windows 7
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

I upgraded to Firefox 22, then I downgraded again.


Actual results:

- All of my per page zoom settings were reset.
- My minimum page setting was reset (and no way to set it again).
- My UI font settings were changed.
- My CSS changes were revoked.


Expected results:

The UI should look exactly as it does in Firefox 21 to remain usable.

Firefox 22, to me, felt like the "I hate you, disabled person. I hate you for your inferiority. I hate you for your needs. I hate you for your very existence." edition to me. And whilst that might sound extreme. Take a look at what it did to understand why. I had to downgrade to Fx 21, it was my only choice.

I have a very specific set of disabilities. I have nystagmus, I have a degenerative optic nerve condition, and I have visual processing problems. I had to tailor Firefox to look just how I wanted it. I've been using Firefox since it was named Phoenix back in version 0.6, and every (and I stress every) version of Firefox has allowed me to tailor it to my needs.

My browser NEEDS to be of a different DPI than my desktop. I, as a disabled person, do not want my browser to share my desktop DPI. I want to be able to configure my browser how I need it, as a person with special aids.

As part of a group of people with similar special needs, I vehemently urged them away from Firefox 22, and none of us are using it. If you look at 'firefox 22 dpi' on the Internet, all you'll see are complaints. And these are going to be complaints from people in a similar situation as me, who have special needs.

It feels cruel, it feels like you hate me, and I don't understand why.

I'm not allowed to have WebRTC, I'm not allowed to have the latest security updates, and why? All because of coder pride, that you think it's the RIGHT choice. I can understand why. Coding is a very, very insular situation, and you exist within an sphere of self-affirmation, where everyone else confirms what you think is right. With an open source project, you only have yourself and your coder group to check with, you don't have focus testing groups.

So you make decisions like this -- obvious everyone wants HiDPI. No one would EVER want an option to turn it off. Why would people want options?

What promise was Firefox built upon, again?

Oh yeah -- that the user would always be able to use the browser in the way they wanted, and that that right would never be taken away from them. So why has Mozilla turned away from that and shown such hate for disabled people?

Give me one good reason why I can't just turn HiDPI off and have Firefox behave like it did in 21. Why shouldn't that be my choice?
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → General
Keywords: access
Version: 21 Branch → 24 Branch

Comment 1

5 years ago
You should post your question on the official support question, see https://support.mozilla.org/en-US/questions to have sme help.

Snce v22, Firefox is aware of the system DPI settings (the value set for the screen resolution, like 125%) which is applied to render the UI and web content.

In your current profile, you need to reset the previous zoom levels, because now, with the default Windows DPI, it's enough to display correctly websites without playing the zoom.

Anyway, in about:config, you can play with layout.css.devPixelsPerPx to change the DPI value, but it's not adviced.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851268

Comment 2

5 years ago
NoSquint should do what you're asking, and it's actually designed around accessibility, unlike DPI settings. Also see Bug 892888 where they're discussing adding a built-in NoSquint since this affects a lot of people. Firefox 21 and under didn't let you change the default zoom either, they just used a different one.

What I don't understand is why focus your attention on why Firefox doesn't allow overriding DPI, when other programs like MSWord and Notepad don't allow you to override DPI either?

If you want to talk accessibility, how accessible is it when the entire website fits behind one hand, like it does on high DPI monitors with Firefox 21?
You need to log in before you can comment on or make changes to this bug.