Australis: in customization mode, the awesome bar should have a Firefox identity button and the reload button should show

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ge3k0s, Assigned: bwinton)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 29
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P5])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In customization mode the awesome bar doesn't show the reload button in it. It should be visible. It would also be nice to have the "firefox page" indicator visible to show that the page is secure.
(Reporter)

Updated

5 years ago
Blocks: 872617
Whiteboard: [Australis:M?][Australis:P4]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: The awesome bar isn't depicted correctly in customization mode → Australis: in customization mode, the awesome bar should have a Firefox identity button and the reload button should show
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M?][Australis:P5]
(In reply to Guillaume C. [:ge3k0s] from comment #1)
> In customization mode the awesome bar doesn't show the reload button in it.
> It should be visible.

Out of curiosity, why? You won't be able to interact with it...
Flags: needinfo?(ge3k0s)
(Reporter)

Comment 2

5 years ago
I'm no visual designer, but I think it would be clearly better to show things as they are even out of Customization mode. if you're not convinced maybe we should ask UX if it's better or not.
Flags: needinfo?(ge3k0s)
(Reporter)

Comment 3

5 years ago
*in customization mode
Per comment #2. Reload button, yes or no?
Flags: needinfo?(shorlander)
Not a very strong preference but I do think we should show it for users who wonder "where is my reload button".

And for the "Firefox identity in the awesome bar", when we have a favicon for customization mode we probably don't need more identity in the awesome bar.

Comment 6

5 years ago
I'm noticing that in customization mode the reload/stop button is in the address bar and can't be moved anymore at a custom position (this was possible in Firefox 25 and before). I'm not sure but is this report among other things talking about this?
(In reply to sworddragon2 from comment #6)
> I'm noticing that in customization mode the reload/stop button is in the
> address bar and can't be moved anymore at a custom position (this was
> possible in Firefox 25 and before). I'm not sure but is this report among
> other things talking about this?

No.

Comment 8

5 years ago
In that case, filed bug 940342 for not being able to move reload/stop button.
(Assignee)

Updated

5 years ago
Assignee: nobody → bwinton
(Assignee)

Comment 9

5 years ago
Created attachment 8362700 [details] [diff] [review]
A first cut at the patch to show stuff in customize mode.

Would something like this work?

(Screenshot at https://www.dropbox.com/s/obakua77xbz661y/Screenshot%202014-01-20%2017.11.57.png )
Attachment #8362700 - Flags: ui-review?(shorlander)
Attachment #8362700 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8362700 [details] [diff] [review]
A first cut at the patch to show stuff in customize mode.

I'll buy that for a dollar. :-)

(assuming you get ui-r+)
Attachment #8362700 - Flags: review?(gijskruitbosch+bugs) → review+
Egh. Is this a half-dupe of bug 869500? Blake?
(Assignee)

Comment 12

5 years ago
I don't think it is, since the favicon appears in the tab, and these appear in the urlbar.
(You can see that my screenshot doesn't have a favicon, and so doesn't fix this bug.  ;)
(Reporter)

Comment 13

5 years ago
(In reply to Blake Winton (:bwinton) from comment #9)
> Created attachment 8362700 [details] [diff] [review]
> A first cut at the patch to show stuff in customize mode.
> 
> Would something like this work?
> 
> (Screenshot at
> https://www.dropbox.com/s/obakua77xbz661y/Screenshot%202014-01-20%2017.11.57.
> png )

Looks very nice. It would be even nicer to have "about:customize" greyed out in the location bar next to the identity block.
(Assignee)

Comment 14

5 years ago
It would, but that seems kind of annoyingly hard.  :(
I got halfway there, by adding the following lines to browser/themes/shared/customizableui/customizeMode.inc.css

toolbarpaletteitem > toolbaritem > #urlbar > hbox > hbox > html|*.textbox-input,
toolbarpaletteitem > toolbaritem > * > #urlbar > hbox > hbox > html|*.textbox-input {
  visibility: visible;
}

If you wanted to take that, and run with it, Guillaume, that would be _awesome_!  ;)
Comment on attachment 8362700 [details] [diff] [review]
A first cut at the patch to show stuff in customize mode.

Review of attachment 8362700 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Attachment #8362700 - Flags: ui-review?(shorlander) → ui-review+
(Reporter)

Comment 16

5 years ago
(In reply to Blake Winton (:bwinton) from comment #14)
> It would, but that seems kind of annoyingly hard.  :(
> I got halfway there, by adding the following lines to
> browser/themes/shared/customizableui/customizeMode.inc.css
> 
> toolbarpaletteitem > toolbaritem > #urlbar > hbox > hbox >
> html|*.textbox-input,
> toolbarpaletteitem > toolbaritem > * > #urlbar > hbox > hbox >
> html|*.textbox-input {
>   visibility: visible;
> }
> 
> If you wanted to take that, and run with it, Guillaume, that would be
> _awesome_!  ;)

Sadly my coding skills are close to nothing so I can't really help here. It's fine without it too. ;)
https://hg.mozilla.org/integration/fx-team/rev/42f136d90d85
Status: NEW → ASSIGNED
Flags: needinfo?(shorlander)
Whiteboard: [Australis:M?][Australis:P5] → [Australis:P5]
https://hg.mozilla.org/mozilla-central/rev/42f136d90d85
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Depends on: 964206

Comment 19

5 years ago
This still isn't fixed for me, I'm using Nightly 06/02/14
(In reply to Tim Nguyen [:ntim] from comment #19)
> This still isn't fixed for me, I'm using Nightly 06/02/14

I suspect this is bug 964206 which was duped to bug 908534. Can you confirm that, and/or file a new bug if switching tabs doesn't make the indicator appear? Thank you!

Updated

5 years ago
QA Contact: cornel.ionce
Verified fixed on Windows 7 64bit, Mac OS X 10.9 and Ubuntu 13.10 using latest Aurora (build ID: 20140306004001).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.