Closed Bug 925690 Opened 8 years ago Closed 8 years ago

Bookmark bar covers the navbar when a flash video is playing in another window

Categories

(Firefox :: Theme, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: u428464, Unassigned)

References

Details

(Whiteboard: [Australis:M?][Australis:P3])

Attachments

(1 file)

STR :
1. Open a window with a flash video playing.
2. Re-size another window by pushing it on the edge of the screen (Windows Aero functionality).
3. Result : the window covers the half of the screen as expected but the bookmarks bar is "pushed up" and covers half of the navbar.
Clearly seems Australis related since I can't reproduce on classic Nightly.
Whiteboard: [Australis:M?][Australis:P3]
(In reply to Guillaume C. [:ge3k0s] from comment #1)
> Clearly seems Australis related since I can't reproduce on classic Nightly.

You don't have shumway enabled, do you? :-)
I can't reproduce this at all. Can you provide more detailed steps to reproduce? Screencast? Regression range? (any of these would help)
Nope it's disabled. ;-)

But the steps to reproduce are hard to explain because it doesn't always happen. If I found more precise ones I'll post here.
Attached image Graphic bug.png
All I can add for now a screenshot of the issue.
(In reply to Guillaume C. [:ge3k0s] from comment #5)
> Created attachment 815823 [details]
> Graphic bug.png
> 
> All I can add for now a screenshot of the issue.

You've got youtube open in a tab there. I understood that the video was playing in another window? Maybe you just play more video than I do... but please clarify. :-)

Other than that... what add-ons are installed on this profile, can you provide the output of the "browser.uiCustomization.state" pref, and does this happen if you disable the add-ons / on a clean profile?

Thanks!
Youtube video is in HTML5 it doesn't seem related since I can also sometimes reproduce without it. The video was indeed in another window (dailymotion).

I have just adblock plus installed and here are my browser.uiCustomization.state :

browser.uiCustomization.state;{"placements":{"PanelUI-contents":["zoom-controls","new-window-button","privatebrowsing-button","save-page-button","print-button","history-panelmenu","find-button","preferences-button","add-ons-button","developer-button"],"addon-bar":["addonbar-closebutton","status-bar"],"PersonalToolbar":["personal-bookmarks"],"nav-bar":["urlbar-container","webrtc-status-button","search-container","social-share-button","bookmarks-menu-button","downloads-button","social-toolbar-item","widget:jid1-c3QwVRywqrH2iA@jetpack-smart-bookmarks"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button","tabs-closebutton"],"toolbar-menubar":["menubar-items"]},"seen":[],"dirtyAreaCache":["PanelUI-contents","nav-bar","addon-bar","PersonalToolbar","TabsToolbar","toolbar-menubar"]}

I'm sorry not to be able to provide more info right now. In fact I've been seeing this bug for quite a long time, but I haven't been able to find clear STR.
All I know is that it clearly seems related to the Windows Vista/7 functionality when pushing windows on the edges of the screen
Guillaume, are you still seeing this? If you are, would you be able to try poking at this with DOM Inspector the next time it happens and try to figure out what's happened to the navbar/bookmarks toolbar?

Separate questions:

- does that scrollbar scroll everything in the toolbox, or just the bookmarks bar, or nothing?
- apart from resizing the window, have you found a way to fix it? Does e.g. closing the tab with the video, or switching apps/windows help at all?
- Does resizing the window help? If so, can you describe in more detail if it 'snaps back' to being correct as soon as you resize it at all, or if you essentially need to drag the window out until the scrollbar goes away?
Whoops, meant to set needinfo. :-)
Flags: needinfo?(ge3k0s)
I've tried it a bit and I've been unable to reproduce the issue. I will reopen this bug if it happens again. To briefly answer your questions:

-It was just the bookmark bar AFAIR
-No the only way was to resize the window
-The scroll bar wasn't really the issue. The issue was the bookmark bar pushed up into the nav bar.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Flags: needinfo?(ge3k0s)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.