The built in Element inspector does not detect a file input element correctly

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: nativist.bill.cutting, Unassigned)

Tracking

17 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 815875 [details]
test.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20130215125822

Steps to reproduce:

The element with id file_input is not detected by the element inspector.

I have reproduced the issue in a fiddle here and provided a screenshot of the issue as an attachment.

http://jsfiddle.net/c3wFY/24/


Actual results:

Only part of the element was detected.

A full description is available here on Stackoverflow.

http://stackoverflow.com/questions/18981839/something-is-breaking-this-jqueryui-dialog-what-is-it/19320584#19320584


Expected results:

The entire element should be detected.

Because it did not detect the entire element, I had a difficult time troubleshooting what was going on.
Component: Untriaged → Developer Tools: Inspector
Created attachment 816954 [details]
925764.png

Hi Bill,

Thanks for volunteering to fix this bug.  However, I'm unable to reproduce the problem.  It looks like you're using Firefox 17, and I've attached a screenshot of what your example looks like for me on 17.  As you can see, the inspector has selected the entire upload input.

17 is a year old, though, so I also tried reproducing on Nightly, which is version 27, and the problem doesn't happen there, either, and the input element looks nicer.

So I'm not sure why you're seeing different results.  In any case, please try to test with the current version of Firefox, because it looks like the way that Firefox lays out your example has changed in recent versions.
(Reporter)

Comment 2

4 years ago
The attachment you provided confirms what I'm seeing as well.  The dotted line should continue to the right and encompass both the remaining file input area and the file input button as they are all part of the same element.  I know it looks like it is encompassing the file input, but this is an artificially created file input I created.  The actual file input is not fully detected.  This is very coincidental and bizarre even.  But if you scroll over the file input button with the mouse, you will see the dotted line appear around the artificially created input "file_fake".  It should appear around the element "file_input".  This fiddle makes it a bit easier to see - http://jsfiddle.net/c3wFY/27/
I see.  I don't know what the problem is, but there's a lot of CSS and markup there.  Regardless, on Nightly, the inspector does select the entire input including the Browse button, so if there is a bug here, it looks like it's been fixed.  You can try on Nightly and see.
(Reporter)

Comment 4

4 years ago
I don't know what you mean by "Try the Nightly".  I am sleepy though.  I noticed on your previous comment, you posted an attachment.  Can you post an attachment of the inspector selecting the entire input.  A picture is worth a thousand words!  Thanks!  Can you confirm the bug for the said version?
Created attachment 818093 [details]
Nightly screenshot

Firefox Nightly, which is built from the latest source code: http://nightly.mozilla.org/

We don't keep bugs open if they've been fixed in the latest code unless there's some unusual reason to do so, and since it appears that Nightly behaves as you expect by selecting the entire file input including the Browse button, I'm going to resolve this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.