Closed Bug 925774 Opened 6 years ago Closed 6 years ago

[en] Keyboard access keys for various attachments commands should be more consistent if possible (change access key for Composition's File | Attach to "h", same as for message reader's Message | Attachments)

Categories

(Thunderbird :: General, enhancement)

24 Branch
x86_64
Windows 7
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: srogers, Assigned: bugzilla2007)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Open a message containing an attachment.
Press Alt + M, H to access Attachments submenu.
Compose a new message.
Press Alt + F, T to access Attachments submenu.


Actual results:

Attachments submenus open but require memorizing different hotkeys.


Expected results:

Hotkeys should be consistent when possible.  This inconsistency was even more irritating when both Attachments submenus were under the File menu, so the shortcuts were Alt + F, A or Alt + F, T depending on whether you were composing or reading.  The sensible thing to me would be to have left them both on the File menu, since Attachments of any type are in fact files, but to have made the shortcut keys the same.  Now in v.24 (I just upgraded from 17), I find uploading an attachment on the File menu but downloading on the Message menu, and again, with inconsistent shortcuts.  Could "H" be the consistent access key for Attachments, no matter where they are accessed? (I note in Bug 307824 that the Sort menu is about to be changed to use M to sort by Attachments -- now there's going to be THREE keys to memorize!!)
Component: Untriaged → General
I don't think there's much value in this. In order to pick a consistent access key for all uses of the words "Attach" or "Attachment" in the menus, we'd have to make other, more important menu items use harder-to-remember access keys.

"Attach"/"Attachment" is used in at least 5 places: 1) Message -> Attachments, 2) View -> Sort By -> Attachments, 3) View -> Display Attachments Inline, 4) Compose -> File -> Attach, and 5) in "N attachments" in the compose window attachment pane.

We can't use A, since "Sort by -> _A_scending" is higher-priority (see bug 307824). Likewise, T is used by "Sort by -> _T_hreaded" and "Compose -> Tools". C is used by "Message -> Copy To" and "Compose -> File -> Close". "H" is used by "Compose -> Help" and "View -> Headers". Those are all the letters in the word "attach", so every letter is already used by much more important menu items, some of which are top-level menus!
(In reply to Jim Porter (:squib) from comment #1)
> I don't think there's much value in this. In order to pick a consistent
> access key for all uses of the words "Attach" or "Attachment" in the menus,
> we'd have to make other, more important menu items use harder-to-remember
> access keys.

+1

> "Attach"/"Attachment" is used in at least 5 places: 1) Message ->
> Attachments, 2) View -> Sort By -> Attachments, 3) View -> Display
> Attachments Inline, 4) Compose -> File -> Attach, and 5) in "N attachments"
> in the compose window attachment pane.

Actually, at least 6: Attachment reminder notification has [_Add Attachment...] button which btw competes with Contact Side bar's [_Add to To] but they both seem to work focus-dependent.

> We can't use A, since "Sort by -> _A_scending" is higher-priority (see bug
> 307824). Likewise, T is used by "Sort by -> _T_hreaded" and "Compose ->
> Tools". C is used by "Message -> Copy To" and "Compose -> File -> Close".
> "H" is used by "Compose -> Help" and "View -> Headers". Those are all the
> letters in the word "attach", so every letter is already used by much more
> important menu items, some of which are top-level menus!

While agree with the general good intention of Stuart's report, I also agree with Jim that it's virtually impossible to make the access key for all the various attachment commands the same, for the reasons he stated. I think the only thing we could do is to change the current composition access key for File > A_ttach >... so that at least adding and retrieving of attachment via the menus is somewhat consistent, like this:

Compose > _File > Attac_h (current access key: t)
Alt+f,h

3pane > _Message > Attac_hments
Alt+m,h

I think that would be a helpful improvement because as Stuart says, it's already hard enough to memorize that we now add and retrieve attachments on different menus, so it would certainly help if at least the access key for attachments after that would be the same.

Jim, any objections against having Alt+f,h for adding attachments in composition, so it's more consistent with Alt+m,h in message reader?
Severity: normal → enhancement
Summary: Inconsistent keyboard access commands for Attachments → [en] Keyboard access keys for various attachments commands should be more consistent if possible
Yeah, that's fine with me. Lowercase T is a bad letter for an access key anyway, since it's so narrow that it's hard to see the underline.
Assignee: nobody → bugzilla2007
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: [en] Keyboard access keys for various attachments commands should be more consistent if possible → [en] Keyboard access keys for various attachments commands should be more consistent if possible (change access key for Composition's File | Attach to "h", same as for message reader's Message | Attachments)
Patch, as explained in my comment 2, and approved by Jim's comment 3.
Attachment #826357 - Flags: ui-review?(squibblyflabbetydoo)
Attachment #826357 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 826357 [details] [diff] [review]
Patch: Change composition's access key for File | Attach to "h", for consistency with accesskey "h" for message reader's Message | Attachments

Review of attachment 826357 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me. I'm not a UI peer (although I wouldn't mind helping out as one for minor stuff), so I'm redirecting the ui-r? to :bwinton.
Attachment #826357 - Flags: ui-review?(squibblyflabbetydoo)
Attachment #826357 - Flags: ui-review?(bwinton)
Attachment #826357 - Flags: review?(squibblyflabbetydoo)
Attachment #826357 - Flags: review+
Comment on attachment 826357 [details] [diff] [review]
Patch: Change composition's access key for File | Attach to "h", for consistency with accesskey "h" for message reader's Message | Attachments

(In reply to Jim Porter (:squib) from comment #5)
> Comment on attachment 826357 [details] [diff] [review]
> rs=me. I'm not a UI peer (although I wouldn't mind helping out as one for
> minor stuff), so I'm redirecting the ui-r? to :bwinton.

Redirecting to :squib per :bwinton's agreement via pm (2013/11/13) :)
Attachment #826357 - Flags: ui-review?(bwinton) → ui-review?(squibblyflabbetydoo)
Comment on attachment 826357 [details] [diff] [review]
Patch: Change composition's access key for File | Attach to "h", for consistency with accesskey "h" for message reader's Message | Attachments

Review of attachment 826357 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Attachment #826357 - Flags: ui-review?(squibblyflabbetydoo) → ui-review+
Thanks, Jim! :)
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/f4b4f9f6d6e9

Thanks for the patch, Thomas! One request - please make sure that future patches have commit information included. It makes life much easier for those checking in on your behalf.
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
You need to log in before you can comment on or make changes to this bug.