Fix Octane-raytrace regression

RESOLVED FIXED in mozilla27

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jandem, Assigned: jandem)

Tracking

({perf, regression})

27 Branch
mozilla27
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 815897 [details] [diff] [review]
Patch

See the huge big Octane-raytrace regression on AWFY. It's a regression from bug 918584.

It looks like we're no longer caching add-props when the property exists on the prototype. The attached patch fixes it. shu: if you can think of a better fix, please steal.
Attachment #815897 - Flags: review?(shu)
Duplicate of this bug: 925824
Is it possible that this fixes the V8 talos regression, too?  See e.g.

http://mzl.la/1hIlyXX

with corresponding cset range:

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=027a7386406f&tochange=6fef99317f21

which has bug 918584 landed.
(In reply to Nathan Froyd (:froydnj) from comment #2)
> Is it possible that this fixes the V8 talos regression, too?  See e.g.

Yes, this is likely the same issue, as octane inherits most of v8 benchmarks.

Comment 4

5 years ago
Comment on attachment 815897 [details] [diff] [review]
Patch

Review of attachment 815897 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch!
Attachment #815897 - Flags: review?(shu) → review+
Keywords: perf, regression
Version: unspecified → 27 Branch
https://hg.mozilla.org/mozilla-central/rev/35167e0cc319
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.