[B2G] [Contacts] Checkboxes are missing on favorite contacts in export contacts page

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun2)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 816026 [details]
Screenshot of favorite contacts in export contact page

Description:
Contacts in the favorite section of the contact list in the export contacts page do not have checkboxes visible.

Repro Steps:
1) Update Buri to Build ID: 20131011004001
2) Launch the Contacts app.
3) Add contacts to the favorite list if there are none there already.
4) Tap the Settings icon, then Export Contacts.
5) Select any of the export options.
6) Observe the checkboxes next to the favorited contacts.

Actual:
No checkboxes are visible.

Expected:
Checkboxes are visible.

Environmental Variables
Device: Buri 1.2 mozilla RIL
Build ID: 20131011004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/c8e97fd5b94d
Gaia: 79abf09f2b5b6440f43cb5ae44ef6c85c0437e8d
Platform Version: 26.0a2

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=9894
See attached screenshot
The favorite contacts do seem to be selectable, and scrolling down to their normal locations does show the current state of the checkbox.
This feels like something that can be worked around pretty easily - they'll just use the actual contact instead of the favorite. Annoying, but likely not blocking.

Comment 2

5 years ago
I believe this was fixed with the recent uplift to the selection process.  I just retested and cannot reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.