Closed Bug 925879 Opened 6 years ago Closed 6 years ago

remove last remnants of JS_BYTES_PER_WORD

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: froydnj, Unassigned)

References

Details

Attachments

(3 files)

I think these are better served with other things.  One of the patches is debatable.
These should just go, jscpucfg.h should die at some point.
Attachment #816032 - Flags: review?(wmccloskey)
This is a more controversial patch; I think sizeof(void*) is a little clearer here,
but I can see an argument for JS_BYTES_PER_WORD.  If we want to keep JS_BYTES_PER_WORD,
we should put that in jstypes.h along with the definition of JS_BITS_PER_WORD from
bug 925807.
Blocks: 781171
Comment on attachment 816034 [details] [diff] [review]
use sizeof(void*) instead of JS_BYTES_PER_WORD in jsfriendapi.h

Review of attachment 816034 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing review.  |sizeof(void*)| is much better, IMHO.
Attachment #816034 - Flags: review+
Comment on attachment 816032 [details] [diff] [review]
remove vestigal JS_BYTES_PER_WORD/JS_BITS_PER_WORD_LOG2 definitions from jscpucfg.h

Review of attachment 816032 [details] [diff] [review]:
-----------------------------------------------------------------

I'd be happy to see these go, but I can still see uses that you haven't addressed...
Attachment #816032 - Flags: review?(wmccloskey) → feedback+
> I'd be happy to see these go, but I can still see uses that you haven't
> addressed...

Oh, I see in bug 925807 you removed a JS_BYTES_PER_WORD use, but JS_BITS_PER_WORD_LOG2 is still used, no?
And now I see bug 925729.  Bugzilla has a "Depends on" field for a reason!
Comment on attachment 816032 [details] [diff] [review]
remove vestigal JS_BYTES_PER_WORD/JS_BITS_PER_WORD_LOG2 definitions from jscpucfg.h

Review of attachment 816032 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but I think JS_BITS_PER_BYTE_LOG2 is a much nicer and more obvious name than JS_BITMAP_NBITS, so extra points if you convert the latter to the former as well.
Attachment #816032 - Flags: feedback+ → review+
> r=me, but I think JS_BITS_PER_BYTE_LOG2 is a much nicer and more obvious name than JS_BITMAP_NBITS

Er, make that JS_BITS_PER_WORD.
Mmmm, somehow I missed this one.
Attachment #817245 - Flags: review?(n.nethercote)
Attachment #817245 - Flags: review?(n.nethercote) → review+
You need to log in before you can comment on or make changes to this bug.