Failure to forward an email message with certain attachments

VERIFIED DUPLICATE of bug 88303

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 88303
17 years ago
10 years ago

People

(Reporter: Charles Manske, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I tried to forward the email titled:
"Clash of the cyber titans - Tech News - CNET.com sent by vishy@netscape.com
on 7/25/01 to cpd-all@netscapec.com 
It had the url shown above as an attachment. After progressing 84%, it stalled,
and CPU usage went up to 100%. Breaking in the debugger, this is where it was:
NTDLL! 77f6793f()
WS2_32! 776b84ee()
WSOCK32! 776d1173()
_PR_MD_RECV(PRFileDesc * 0x083fc720, void * 0x083fd5a0, int 5, int 0, unsigned
int 4294967295) line 175 + 19 bytes
SocketRecv(PRFileDesc * 0x083fc720, void * 0x083fd5a0, int 5, int 0, unsigned
int 4294967295) line 568 + 25 bytes
pl_DefRecv(PRFileDesc * 0x083fda10, void * 0x083fd5a0, int 5, int 0, unsigned
int 4294967295) line 218 + 34 bytes
ssl_DefRecv(sslSocketStr * 0x083fc950, unsigned char * 0x083fd5a0, int 5, int 0)
line 89 + 34 bytes
ssl3_GatherData(sslSocketStr * 0x083fc950, sslGatherStr * 0x083fd560, int 0)
line 87 + 24 bytes
ssl3_GatherCompleteHandshake(sslSocketStr * 0x083fc950, int 0) line 193 + 17 bytes
ssl3_GatherAppDataRecord(sslSocketStr * 0x083fc950, int 0) line 234 + 13 bytes
DoRecv(sslSocketStr * 0x083fc950, unsigned char * 0x06f14830, int 1576, int 0)
line 505 + 11 bytes
ssl_SecureRecv(sslSocketStr * 0x083fc950, unsigned char * 0x06f14830, int 1576,
int 0) line 1008 + 21 bytes
ssl_SecureRead(sslSocketStr * 0x083fc950, unsigned char * 0x06f14830, int 1576)
line 1017 + 19 bytes
ssl_Read(PRFileDesc * 0x083fd4d0, void * 0x06f14830, int 1576) line 1181 + 21 bytes
nsSSLIOLayerRead(PRFileDesc * 0x069db130, void * 0x06f14830, int 1576) line 626
+ 26 bytes
PR_Read(PRFileDesc * 0x069db130, void * 0x06f14830, int 1576) line 120 + 20 bytes
nsSocketIS::Read(nsSocketIS * const 0x083fb9a0, char * 0x06f14830, unsigned int
1576, unsigned int * 0x0193fe04) line 2256 + 21 bytes
nsReadFromInputStream(nsIOutputStream * 0x083e1d94, void * 0x083fb9a0, char *
0x06f14830, unsigned int 0, unsigned int 1576, unsigned int * 0x0193fe04) line 831
nsPipe::nsPipeOutputStream::WriteSegments(nsPipe::nsPipeOutputStream * const
0x083e1d94, unsigned int (nsIOutputStream *, void *, char *, unsigned int,
unsigned int, unsigned int *)* 0x10056a20 nsReadFromInputStream(nsIOutputStream
*, void *, char *, unsigned int, unsigned int, unsigned int *), void *
0x083fb9a0, unsigned int 8192, unsigned int * 0x0193fe9c) line 704 + 29 bytes
nsPipe::nsPipeOutputStream::WriteFrom(nsPipe::nsPipeOutputStream * const
0x083e1d94, nsIInputStream * 0x083fb9a0, unsigned int 8192, unsigned int *
0x0193fe9c) line 839
nsStreamListenerProxy::OnDataAvailable(nsStreamListenerProxy * const 0x083e48a0,
nsIRequest * 0x083e1b70, nsISupports * 0x083e3144, nsIInputStream * 0x083fb9a0,
unsigned int 472, unsigned int 8192) line 288 + 38 bytes
nsSocketReadRequest::OnRead() line 2701 + 57 bytes
nsSocketTransport::doReadWrite(short 1) line 999 + 14 bytes
nsSocketTransport::Process(short 1) line 480 + 13 bytes
nsSocketTransportService::Run(nsSocketTransportService * const 0x01257fb4) line
419 + 13 bytes
nsThread::Main(void * 0x01257a10) line 105 + 26 bytes

I first saw this problem in the current 0_9_2 branch build, and it also exists
in the trunk build
I've seen similar lockup trying to include this particular image file in an
email:
http://www.jivamedia.com/SolarEclipse2001/Mid-Inner-Composite.jpg
(Assignee)

Comment 1

17 years ago
I'm pretty sure this is a dup of a SSL bug owned by PSM. I'll see if I can find it
(Assignee)

Comment 2

17 years ago
cmanske, in the mean time, to get rid of this problem just edit your SMTP
settings  and set use TLS to NEVER. 

Edit / Mailnews Account Settings
The click on outgoing server. Select the never option for use TLS. 
(Assignee)

Comment 3

17 years ago
This is a dup of 88303.

*** This bug has been marked as a duplicate of 88303 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
mscott: Thanks! I was very suspicious that it was a security code issue.
I don't recall changing anything when I installed, but maybe the Cert
installation changed that setting? I'm just concerned about the average user who
might also install a cert. Do we set the SSL pref as "never" for a default install?
default? That will help everyone else avoid the same problem until bug 88303 is
fixed (since current milestone is 2.1!)

Comment 5

17 years ago
Mark it verified/dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.