[B2G][Email] Unable to download an email attachment again if the file was deleted

RESOLVED DUPLICATE of bug 1109376

Status

RESOLVED DUPLICATE of bug 1109376
5 years ago
4 years ago

People

(Reporter: mvaughan, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2)

(Reporter)

Description

5 years ago
Description:
If a file was deleted after it was downloaded from an email, the download button within the email does not change back from the word "View" to the down arrow even after synchronizing the Inbox again. The repro steps will use an image as an example, but this can happen with other file types.

Repro Steps:
1) Update Buri to BuildID: 20131011004001
2) Launch the Email app
3) Set up a new email account on the phone
4) From another device, send an email, with a JPEG attached, to the phone
5) Open the email on the phone and download the attachment
6) Navigate to the Gallery app and delete the image
7) Navigate back to the email
8) Attempt to download the image again

Actual:
User is unable to download the attachment again.

Expected:
User is able to download the attachment again.

Environmental Variables:
Device: Buri
BuildID: 20131011004001
Gaia: 79abf09f2b5b6440f43cb5ae44ef6c85c0437e8d
Gecko: c8e97fd5b94d
Version: 26.0a2

Notes:
Repro frequency: 100%
Optional Workaround: There are two ways to work around this issue. 1) Move the email from the Inbox to another folder (ex: Trash) using another device and then sync the phone. 2) Delete and then set up the account again on the phone.
(Reporter)

Comment 1

5 years ago
This bug also occurs on the 10/11/13 1.1 build.

Environmental Variables:
BuildID: 20131011041214
Gaia: 680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
Gecko: cb2a1a27a94c
Version: 18.0
status-b2g18: --- → affected
status-b2g-v1.2: --- → affected
(Reporter)

Updated

5 years ago
Whiteboard: burirun2

Updated

5 years ago
Duplicate of this bug: 980726
duping forward to explicitly triaged bug
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109376
You need to log in before you can comment on or make changes to this bug.