Cannot print to file on Windows?

VERIFIED INVALID

Status

()

Core
Printing: Output
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: David Karr, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2+)
Gecko/20010727
BuildID:    2001072703

I might be missing something simple, but there doesn't seem to
be a capability to print to file on Windows.

Reproducible: Always
Steps to Reproduce:
1. Select Print menu option
2.
3.

Actual Results:  Dialog appears with no option to print to file.

Expected Results:  Should have some option before submitting the print job to
print to file.
(Assignee)

Comment 1

17 years ago
You have to install the driver.. there are drivers on windows.. when you make a 
new printer. you select the port you want to go to.. and you can select file.. 
thats how windows works.. this is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
I believe you are mistaken.  The standard Windows Common Print Dialog, invoked
using the PrintDlg() routine from Comdlg32, shows a "Print to file" checkbox
that is present no matter which printer driver is installed.

It looks like (guessing, of course) Mozilla has extended the common print dialog
and added the "Print Frames" section.  If this is true, then the code is
probably explicity using the PD_HIDEPRINTTOFILE flag to hide the "Print to file"
checkbox.  If Mozilla is not using the common print dialog, then it is simply an
oversight that Mozilla's version of the dialog does not have such a checkbox.

In any case, it is a bug in Mozilla and is not invalid.

Comment 3

17 years ago
Don ?
(Assignee)

Comment 4

17 years ago
Yes.. there is a print to file check box which we disabled because it was 
decided not to support printing to a file. The reason was because there are work 
arounds like the one I described, which makes this bug invalid.

Comment 5

17 years ago
I think you should refile this as an RFE.  Mark it future if you want, but your
reasoning for your currently deliberately broken implemenation does not hold up.

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 7

16 years ago
*** Bug 136982 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.