Closed Bug 925963 Opened 6 years ago Closed 6 years ago

poppit is rendered upside down on hamachi and leo

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sotaro, Unassigned)

References

Details

(Keywords: regression)

On v1.2/master hamachi/leo, poppit app is rendered upside down. on nexus-4, it is rendered correctly.

Poppit could be got from Marketplace or attachment 810588 [details] in Bug 918978.
On hamachi and leo device, when disabling SkiaGL, the problem is gone.
  http://mxr.mozilla.org/mozilla-central/source/b2g/app/b2g.js#821

It seems like to related to SkiaGL/accelerated canvas.
blocking-b2g: --- → koi?
QA Contact: sparsons
Unable to reproduce on Buri 1.2 Aurora BuildID 20131014004003

Gaia   d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
SourceStamp 690f28662ace
BuildID 20131014004003
Version 26.0a2

Also, Unable to reproduce on Buri Master BuildID 20131014040204

Gaia   f240abf567325d486c3d0434791b1d132cfa327a
SourceStamp 211337f7fb83
BuildID 20131014040204
Version 27.0a1
Sarah, are you saying the problem is gone, or are you saying that it was OK on those builds, but not OK on some newer builds?
Milan,

Yes, per comment 2, the issue is no longer reproducing. 

(In reply to Milan Sreckovic [:milan] from comment #3)
> Sarah, are you saying the problem is gone, or are you saying that it was OK
> on those builds, but not OK on some newer builds?
(In reply to Sarah Parsons from comment #4)
> Milan,
> 
> Yes, per comment 2, the issue is no longer reproducing. 
> 
> (In reply to Milan Sreckovic [:milan] from comment #3)
> > Sarah, are you saying the problem is gone, or are you saying that it was OK
> > on those builds, but not OK on some newer builds?

I'm not sure you tested this correctly. How do you know that Poppit is rendered upside down or not? Did you compare the implementation against 1.1?
Flags: needinfo?(sparsons)
I compared to the 1.1 Build ID: 20131014041201 this morning, both render and play correctly. 

Gaia   680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
SourceStamp cb2a1a27a94c
BuildID 20131014041201
Version 18.0

Also, I compared poppit on from my personal device (Galaxy S3) they all display and play the same way. 


(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to Sarah Parsons from comment #4)
> > Milan,
> > 
> > Yes, per comment 2, the issue is no longer reproducing. 
> > 
> > (In reply to Milan Sreckovic [:milan] from comment #3)
> > > Sarah, are you saying the problem is gone, or are you saying that it was OK
> > > on those builds, but not OK on some newer builds?
> 
> I'm not sure you tested this correctly. How do you know that Poppit is
> rendered upside down or not? Did you compare the implementation against 1.1?
Flags: needinfo?(sparsons)
Sounds like this is a wfm then.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.