java.lang.NullPointerException at org.mozilla.gecko.home.TabMenuStrip.onPageScrolled(TabMenuStrip.java:107)

RESOLVED DUPLICATE of bug 926402

Status

()

RESOLVED DUPLICATE of bug 926402
5 years ago
5 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

26 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Pretty confident that this has nothing to do with Bug 919768, which just landed on Aurora.

This error means that setScrollingData is setting a null fromTab, which is when getChildAt(position + 1) or (position) returns null, which seems pretty likely.

These methods look quite unsafe.

Code looks unchanged on trunk.


https://tbpl.mozilla.org/php/getParsedLog.php?id=29014872&tree=Mozilla-Aurora

17:26:26     INFO -  EventExpecter: no longer listening for Gecko:Ready
17:26:26     INFO -  2 INFO TEST-PASS | testHistory | waiting for urlbar text to gain focus - urlbar text gained focus
17:26:26     INFO -  3 INFO TEST-PASS | testHistory | URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_01.html
17:26:26     INFO -  EventExpecter: no longer listening for DOMContentLoaded
17:26:26     INFO -  4 INFO TEST-PASS | testHistory | Page title is correct - Browser Blank Page 01 should equal Browser Blank Page 01
17:26:26     INFO -  5 INFO TEST-PASS | testHistory | waiting for urlbar text to gain focus - urlbar text gained focus
17:26:26     INFO -  6 INFO TEST-PASS | testHistory | URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_02.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_02.html
17:26:26     INFO -  EventExpecter: no longer listening for DOMContentLoaded
17:26:26     INFO -  7 INFO TEST-PASS | testHistory | Page title is correct - Browser Blank Page 02 should equal Browser Blank Page 02
17:26:26     INFO -  8 INFO TEST-PASS | testHistory | waiting for urlbar text to gain focus - urlbar text gained focus
17:26:26     INFO -  9 INFO TEST-PASS | testHistory | URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_03.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_03.html
17:26:26     INFO -  EventExpecter: no longer listening for DOMContentLoaded
17:26:26     INFO -  10 INFO TEST-PASS | testHistory | Page title is correct - Browser Blank Page 03 should equal Browser Blank Page 03
17:26:26     INFO -  11 INFO TEST-PASS | testHistory | waiting for urlbar text to gain focus - urlbar text gained focus
17:26:26     INFO -  INFO | automation.py | Application ran for: 0:00:44.104261
17:26:26     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpbImNhipidlog
17:26:26     INFO -  /data/anr/traces.txt not found
17:26:26  WARNING -  PROCESS-CRASH | java-exception | java.lang.NullPointerExceptionat org.mozilla.gecko.home.TabMenuStrip.onPageScrolled(TabMenuStrip.java:107)
Steps to reproduce?
Flags: needinfo?(rnewman)
(Reporter)

Comment 2

5 years ago
(In reply to Lucas Rocha (:lucasr) from comment #1)
> Steps to reproduce?

This was an exception recorded on TBPL, not in manual use. See log link in Comment 0 for full context.

This seems like a perfect bug to solve via code reading and mental simulation…
Flags: needinfo?(rnewman)
Not sure how often this is or might be happening. Nominating just in case.
tracking-fennec: --- → ?
java.lang.NullPointerException @ org.mozilla.gecko.home.TabMenuStrip.onPageScrolled(TabMenuStrip.java:107)

looks like DUP of Bug 926402
Indeed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926402
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.