Thunderbird 24.0 Hangs for 20 seconds upon launch/startup with "Unresponsive script" error: Script: chrome://messenger/content/mailWindow.js:173

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: vljahn, Unassigned)

Tracking

({perf, regression})

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB24?])

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Hello, Have been using Thunderbird with excellent results for many years. 

Applied update to TB 24.0 and now TB hangs for 20 seconds after launching with error code: Script: chrome://messenger/content/mailWindow.js:173, 

Also tried starting TB in Safe Mode as well as manually disabling all add-ons and extentions in Thunderbird, Firefox and Google Chrome, but without success. Thunderbird still hands upon start up. 

Also reinstalled Firefox, Google Chrome and Java. But no changes. 


Actual results:

After the hang, Thunderbird behaves normally. 


Expected results:

No Hang. Both POP and IMAP accounts should sync as before without any delays. 

Presently using Windows 7 64x Home, all windows updates are current.
Does problem go away with thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode ?

Does problem go away in *Windows'* safe mode with networking enabled?
- win7 http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode

how many pop accounts?  any gmail?
Flags: needinfo?(vljahn)
1. Does problem go away with thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode ?
NO


Does problem go away in *Windows'* safe mode with networking enabled?
- win7 http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode
NO

how many pop accounts?  any gmail?
There are: 6 POP and 2 IMAP gmail accounts
Flags: needinfo?(vljahn)
Keywords: perf
Summary: Recent Thunderbird 24.0 update caused application Hang for 20 seconds upon launch with error: Script: chrome://messenger/content/mailWindow.js:173 → Thunderbird 24.0 update Hangs for 20 seconds upon launch/startup with "Unresponsive script" error: Script: chrome://messenger/content/mailWindow.js:173
vljahn, thanks for checking.

please also check if problem goes away when started from dos command prompt with
  thunderbird.exe -offline
Issued Dos cmd: thunderbird.exe -offline
No changes noticed. Thunderbird still hangs for 20 seconds after startup then times out with a script error.

Is there an internal trace or log file we can review?

Thanks again
Is your thunderbird profile directory on a network share?
Hi Wayne, 

No sharing at all, including networks, printers and files.
same deal and this is the message I get- Script: chrome://messenger/content/mailWindowOverlay.js:1374
Haven't seen much effort to resolve this issue:  There appears to be an "try this and try that" approach, but these suggestions are very basic and have yet to detect and cure this bug. 

1. Can we roll back the most recent update?

2. Were is the Thunderbird log file, and why does this audit trail indicate?

3. What is the Unresponsive script looking for when it hangs? What is its function? Can the end user turn it off?

4. No one yet has suggested reinstalling Thunderbird without damaging the existing profile. 

5. If Thunderbird is open source, what does the source code say?

6. What changed in the code since the last update that might cause an unresponsive script error?

7. Lets reduce the guessing, and provide everyone with result-producing options.

8. We are on standby awaiting your recommendations.

Thanks again.
If you know how to fix this, feel free to go ahead. 
If you don't, you might let the people experienced in triage try to help you.
1-2 No
3. it's a symptom, not a cause, and it doesn't normally point to the cause
4. it doesn't help
5. please look it up
6. ditto
7-8 please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

once more pressing release issues are resolved then you might see more assistance here. Until then, patience is advised.
Wayne is the CONDSTORE support for gmail disabled in TB24?
Posted file Error Script.html
Hi, I don't have this bug but a user who speaks Spanish reported a similar situation in Mozilla Hispano's support forum. He sent me his Troubleshooting information and I uploaded here. I hope it helps to find and solve this bug.
Just a note: the report in Spanish was added here
https://www.mozilla-hispano.org/foro/viewtopic.php?f=3&t=16873&p=65465#p65465
Still having this problem using 24.1.1 on Win7.
(In reply to anyoneforagameoftabletennis from comment #13)
> Still having this problem using 24.1.1 on Win7.

where did you come from?  :)


Does problem reproduce if you use https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/23.0b1/win32/en-US/Thunderbird%20Setup%2023.0b1.exe ??

Backup your Thunderbird profile before using this older unreleased version. mozbackup is one good choice
Flags: needinfo?(vljahn)
Flags: needinfo?(anyoneforagameoftabletennis)
See Also: → 939462
per reporter "subsequent TB updates fixed the issue and since then things have been behaving fine.  Feel free to close out this bug. "
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(vljahn)
Flags: needinfo?(anyoneforagameoftabletennis)
Resolution: --- → WORKSFORME
the bug is still there for me, from 18.0b1 and up to 30.0b1 (didn't test 25,26,27,28,29 but every version from 18.0b1 to 24.5
with 17.0.11esr Thunderbird starts without problems...
(In reply to Andreas Ziegler from comment #16)
> the bug is still there for me, from 18.0b1 and up to 30.0b1 (didn't test
> 25,26,27,28,29 but every version from 18.0b1 to 24.5
> with 17.0.11esr Thunderbird starts without problems...

Start *Windows'* safe mode with networking enabled
- win8 http://windows.microsoft.com/en-US/windows-8/windows-startup-settings-including-safe-mode
- win7 http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode
- XP http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx

Still In Windows safe mode, start thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode

Does problem go away?
Flags: needinfo?(mozilla-bugzilla)
thanks four your reply.
i booted Windows 7 in safe mode and started thunderbird 24.5.0 in safe mode there - the problem persists :(
Flags: needinfo?(mozilla-bugzilla)
(In reply to Andreas Ziegler from comment #18)
> thanks four your reply.
> i booted Windows 7 in safe mode and started thunderbird 24.5.0 in safe mode
> there - the problem persists :(

Please post your issue at https://support.mozilla.org/en-US/questions/new/thunderbird or file a new bug report ... and post the link here.
I recently updated Thunderbird to version 31.3.0 and started getting this error. To recap, when I start up Thunderbird I get about a 25 second white screen pause and then get the following popup error:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://messenger/content/mailWindow.js:180"

Also, I'm running Chrome version 39.0.2171.71 m

Is there any update on this bug for the current version of Thunderbird?
(In reply to Andreas Ziegler from comment #20)
> bug 1019969

FWIW, Andreas' bug - Thunderbird 18-30b1 gets "Unresponsive script" 45 seconds after launch/startup. - was closed WFM for version 31.0


(In reply to gcaxp from comment #21)
> I recently updated Thunderbird to version 31.3.0 and started getting this
> error. To recap, when I start up Thunderbird I get about a 25 second white
> screen pause and then get the following popup error:

gcaxp, 
You updated from version 24?
How many accounts and folders?
Flags: needinfo?(gcaxp)
Summary: Thunderbird 24.0 update Hangs for 20 seconds upon launch/startup with "Unresponsive script" error: Script: chrome://messenger/content/mailWindow.js:173 → Thunderbird 24.0 Hangs for 20 seconds upon launch/startup with "Unresponsive script" error: Script: chrome://messenger/content/mailWindow.js:173
I don't recall from which version I upgraded. My current install is set to work with 7 accounts.
Flags: needinfo?(gcaxp)
(In reply to gcaxp from comment #23)
> I don't recall from which version I upgraded. My current install is set to
> work with 7 accounts.

Suggest you try Thunderbird 37 beta in about 3 weeks from http://www.mozilla.org/en-US/thunderbird/channel/  If it happens then with Thunderbird started in safe mode then please file a new bug report.
Is the line number in the error message changing or is it constant? If constant can you paste the current line number (from TB31.4)?
I have since upgraded to Earlybird (38.0a2) and continue to experience similar (if not the same) issues. I will start a new bug post.
Hello to all,

I am using Thunderbird (ver. 31.7.0) for Linux.

I experienced the same problem today. It appeared after having tweaked the preferences menu. I finally figured out how to fix the issue regarding the error message : [ Script: chrome://messenger/content/mailWindowOverlay.js:1390 ]. Here it goes (at least, this worked great for me): 

> Source of the problem:
Change in “Preferences” menu: configuration change of the proxies to access the Internet. (see: Preferences > Advanced > Network & Disk Space > Connection > Settings)

> Explanation:
By default, “Use system proxy settings” is selected.
If changing this setting to “Auto-detect proxy settings for this network”, then the problem arises.

> how to solve the problem? There are two ways:

OPTION 1:
>> Open Thunderbird
>> Go to:  Preferences > Advanced > Network & Disk Space > Connection > Settings and select: “Use system proxy settings”.
>> Click “OK” and restart Thunderbird.

OPTION 2:
>> If Option 1 here above does not solve the issue -- or if you cannot even start Thunderbird anymore -- then make sure that Thunderbird is closed and not running.
>> Go to the user's profile folder (for example, in Linux it is here: /home/user/.thunderbird/user_profile)
>> Look for the hidden file: “prefs.js” and edit it in a text editor. (To see hidden files, press the combination keys: Ctrl-h.).
>> Search for the following line: user_pref("network.proxy.type", 4);
>> Either delete the line, or place a “#” at the beginning of it to deactivate the command line, like this: # user_pref("network.proxy.type", 4);
>> Save the file and close.
>> Restart Thunderbird.

I hope this helps!

Cheers,

Matt
(In reply to Matt from comment #27)
> Hello to all,
> 
> I am using Thunderbird (ver. 31.7.0) for Linux.
> 
> I experienced the same problem today. It appeared after having tweaked the
> preferences menu. I finally figured out how to fix the issue regarding the
> error message : [ Script:
> chrome://messenger/content/mailWindowOverlay.js:1390 ]. Here it goes (at
> least, this worked great for me): 
> 
> > Source of the problem:
> Change in “Preferences” menu: configuration change of the proxies to access
> the Internet. (see: Preferences > Advanced > Network & Disk Space >
> Connection > Settings)
> 
> > Explanation:
> By default, “Use system proxy settings” is selected.
> If changing this setting to “Auto-detect proxy settings for this network”,
> then the problem arises.
> 
> > how to solve the problem? There are two ways:
> 
> OPTION 1:
> >> Open Thunderbird
> >> Go to:  Preferences > Advanced > Network & Disk Space > Connection > Settings and select: “Use system proxy settings”.
> >> Click “OK” and restart Thunderbird.
> 
> OPTION 2:
> >> If Option 1 here above does not solve the issue -- or if you cannot even start Thunderbird anymore -- then make sure that Thunderbird is closed and not running.
> >> Go to the user's profile folder (for example, in Linux it is here: /home/user/.thunderbird/user_profile)
> >> Look for the hidden file: “prefs.js” and edit it in a text editor. (To see hidden files, press the combination keys: Ctrl-h.).
> >> Search for the following line: user_pref("network.proxy.type", 4);
> >> Either delete the line, or place a “#” at the beginning of it to deactivate the command line, like this: # user_pref("network.proxy.type", 4);
> >> Save the file and close.
> >> Restart Thunderbird.
> 
> I hope this helps!
> 
> Cheers,
> 
> Matt

I can confirm above finding for TB 38.4.0 on Ubuntu 14.04
Initial setting “Use system proxy settings” gives repreducable "Unresponsive script" when opening large(?) inbox (~8000 emails, 845 Mb)
Changing setting to some other value comppletely renders TB unresponsive, with CPU load at over 100%
(In reply to niels+github from comment #28)
> (In reply to Matt from comment #27)
> > Hello to all,
> > 
> > I am using Thunderbird (ver. 31.7.0) for Linux.
> > 
> > I experienced the same problem today. It appeared after having tweaked the
> > preferences menu. I finally figured out how to fix the issue regarding the
> > error message : [ Script:
> > chrome://messenger/content/mailWindowOverlay.js:1390 ]. Here it goes (at
> > least, this worked great for me): 
> > 
> > > Source of the problem:
> > Change in “Preferences” menu: configuration change of the proxies to access
> > the Internet. (see: Preferences > Advanced > Network & Disk Space >
> > Connection > Settings)
> > 
> > > Explanation:
> > By default, “Use system proxy settings” is selected.
> > If changing this setting to “Auto-detect proxy settings for this network”,
> > then the problem arises.
> > 
> > > how to solve the problem? There are two ways:
> > 
> > OPTION 1:
> > >> Open Thunderbird
> > >> Go to:  Preferences > Advanced > Network & Disk Space > Connection > Settings and select: “Use system proxy settings”.
> > >> Click “OK” and restart Thunderbird.
> > 
> > OPTION 2:
> > >> If Option 1 here above does not solve the issue -- or if you cannot even start Thunderbird anymore -- then make sure that Thunderbird is closed and not running.
> > >> Go to the user's profile folder (for example, in Linux it is here: /home/user/.thunderbird/user_profile)
> > >> Look for the hidden file: “prefs.js” and edit it in a text editor. (To see hidden files, press the combination keys: Ctrl-h.).
> > >> Search for the following line: user_pref("network.proxy.type", 4);
> > >> Either delete the line, or place a “#” at the beginning of it to deactivate the command line, like this: # user_pref("network.proxy.type", 4);
> > >> Save the file and close.
> > >> Restart Thunderbird.
> > 
> > I hope this helps!
> > 
> > Cheers,
> > 
> > Matt
> 
> I can confirm above finding for TB 38.4.0 on Ubuntu 14.04
> Initial setting “Use system proxy settings” gives repreducable "Unresponsive
> script" when opening large(?) inbox (~8000 emails, 845 Mb)
> Changing setting to some other value comppletely renders TB unresponsive,
> with CPU load at over 100%

Hi Matt,
had the ...mailWindow.js.. Error too.

Thanks for your effort! Option 1 was the solution for me.
Details: Ubuntu 16.04.
Guess the removing and adding of one email account could be the "only" reason. Because worked well for a long time. AND, yes I do have a lot of emails.
Regards
Felix
PS intersting that to see this over years here... and that there is not a smarter hint or solution? :-). Therefore took my (reporting)part here, like others, too.
(In reply to Felix from comment #29)
> ...
> Thanks for your effort! Option 1 was the solution for me.
> Details: Ubuntu 16.04.
> Guess the removing and adding of one email account could be the "only"
> reason. Because worked well for a long time. AND, yes I do have a lot of
> emails.

Felix, can you clarify ... you had not seen this problem before adding another account?
And what version of Thunderbird?

Perhaps you are seeing bug 1245584
Flags: needinfo?(aon.913172518)
Hi!
Additional information:

Thunderbird Version 45.4.0

My Ubuntu was installed ca. In July this year. No update. directly 16.04. so could be that TB was updated after that istallation. As there were no problems..

The emails were taken from thunderbird under windows (dont know now the version, cannot check it now).
All was fine over the month.

Again: the only thing I made, was to remove one account from my (ca 10 accounts) and add a new one (finally the same, but that doesnt matter)...I I thought this could be the "reason" could cause the error. So I searched and find "the long list here ".
hope that helps, too.
Felix
I caught up with some of the early reporters to recheck whether original reports might be related to proxy 

vljan: "Yes it is now gone and I did not change any network settings, thanks. "
gcaxp: "I do not currently experience this issue, but I am no longer using the version of Thunderbird that I was when I first experienced it. I am now using 45.5.0 and don't get any script errors. It does tend to freeze up on me occasionally, becoming completely unresponsive for up to a minute at a time, but no error messages pop up any more. "

Also checked perf bugs created in the same time period - almost 30 in a 4 month period. https://mzl.la/2gG3YOM
* A thunderbird proxy issue was duped to networking bug 923458 which is cited to be a regression against version 25, not version 24, and so no backport to version 24.
* And there is only one open startup bug remaining - Bug 929281 - Long startup and "Unresponsive Script" with many pop accounts with version 24
Component: Untriaged → General
Flags: needinfo?(aon.913172518)
Whiteboard: [regression:TB24?]
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #30)
> (In reply to Felix from comment #29)
> > ...
> > Thanks for your effort! Option 1 was the solution for me.
> > Details: Ubuntu 16.04.
> > Guess the removing and adding of one email account could be the "only"
> > reason. Because worked well for a long time. AND, yes I do have a lot of
> > emails.
> 
> Felix, can you clarify ... you had not seen this problem before adding
> another account?
> And what version of Thunderbird?
> 
> Perhaps you are seeing bug 1245584

Hi, concerning 1245584, no, there was only the message skript: chrome//messanger/content/mailWindow.js:170
thx.
You need to log in before you can comment on or make changes to this bug.