[AR] Missing Arabic character in keyboard - Needs reorganization and using "alt" option

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Nefzaoui, Assigned: Nefzaoui)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v1.4 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment, 2 obsolete attachments)

46 bytes, text/x-github-pull-request
rudyl
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Arabic keyboard is missing a character (*It's mentioned below) which is very essential in writing in Arabic.
My suggestion is that we use alt option and reorganize characters' positions, so ones that look similar can be placed by continuously clicking on its key and possibly have more space for other characters to add.


*The missing character is
ى
(Assignee)

Comment 1

4 years ago
Should I prepare a PR to better showcase what is that all about?
(Assignee)

Updated

4 years ago
Blocks: 906270
(Assignee)

Comment 3

4 years ago
Created attachment 821193 [details] [review]
PR on github
Attachment #821193 - Flags: review?(rlu)
I'm fine with the patch; I just have no clue whether the issue is valid :-) Do we have anyone in the FxOS project who speaks Arabic?
Ping Arky to see if he could help on whom we should consult for this patch.
Flags: needinfo?(hitmanarky)
(Assignee)

Comment 6

4 years ago
AFAIK there are no staff working on Firefox OS speaking Arabic.. :) Though who submitted the Arabic layout in the first place? He'll confirm for us :)
According to my girlfriend, it's a very common character.

Updated

4 years ago
Flags: needinfo?(hitmanarky)

Comment 8

4 years ago
Looping in Anas and Khaled Hosny of Arabic L10N team here. Any feedback?

Comment 9

4 years ago
I have no experience with Firefox OS, but if ى is missing from the layout, it should be added of course, it is just as important as any other letter.
(Assignee)

Comment 10

4 years ago
Which is crystal clear that this character is missing and as Khaled confirmed,  it is as important as any other letter.
I see no reason for this patch not being merged into master :)
(Assignee)

Comment 12

4 years ago
Created attachment 824104 [details] [review]
Github Pull Request

Accidentally merged another bug's commit to this bug's branch.. Had it messed up.
So here's the New PR. My deep apologies for any confusion happened :)
(Assignee)

Updated

4 years ago
Attachment #821193 - Attachment is obsolete: true
Attachment #821193 - Flags: review?(rlu)
(Assignee)

Comment 13

4 years ago
I think that's it for this bug. Can we please merge it ? Or am I missing something? :)
(Assignee)

Updated

4 years ago
Attachment #824104 - Flags: review?(janjongboom)
(Assignee)

Updated

4 years ago
Attachment #824104 - Attachment is obsolete: true
Attachment #824104 - Flags: review?(janjongboom)
Hi Ahmed, can you please mark the correct pull request as not obsolete? At the moment there are 2 attachments that are marked obsolete, so I don't know which one to review. Thanks!
Flags: needinfo?(nefzaoui.ahmed)
(Assignee)

Comment 15

4 years ago
Hi Jan,
due to the code change in master, related to bug 884752 (In which I didn't notice it was lately merged). I will have to rework on this bug according to the changes happened.
Right now both patches are obsolete.

Thank you :-)
Flags: needinfo?(nefzaoui.ahmed)
(Assignee)

Comment 16

4 years ago
Created attachment 8365681 [details] [review]
PR to Github

Took the time in the weekend to work on this.
Jan, may I get this reviewed to me Please? :)
Attachment #8365681 - Flags: review?(janjongboom)
Comment on attachment 8365681 [details] [review]
PR to Github

Stealing the review.
This patch looks good to me, r+.

Thank you.
Attachment #8365681 - Flags: review?(janjongboom) → review+
Merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/e280e42374ae92d1108d29dee93d5b618bc382e1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Assignee: nobody → nefzaoui.ahmed

Comment 19

3 years ago
Verified the issue is fixed on Flame 2.2

The missing character "و" is implemented

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash Eng. build)
BuildID: 20141202040207
Gaia: c142015cba9bc3d7ea8e88f1c425950238f4c2c9
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
Flame 2.2
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 20

3 years ago
Verified the issue is fixed on 1.4, since it was landed on master 01/27

The missing character "ى" is added to the keyboard

Device: Flame 1.4 (319Mb, Full Flash, ENG)
BuildID: 20141203000201
Gaia: 22c80a708329321a2fdeed4ece019498c0cec90d
Gecko: 429d90dd383c
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
status-b2g-v1.4: --- → verified
Mass Edit: adding the [rtl-meta]
Whiteboard: [rtl-meta]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][rtl-impact]
Whiteboard: [rtl-meta]
Blocks: 1071906
No longer blocks: 906270
No longer blocks: 1071906
You need to log in before you can comment on or make changes to this bug.