Closed Bug 926125 Opened 7 years ago Closed 7 years ago

[Buri] [Ringtones] Settings and Music often crash when trying to set a ringtone from the Music app

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 924678

People

(Reporter: marcia, Assigned: djf)

References

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Crash Data

Attachments

(2 files)

Seen while running Buri:

Gaia   e0f8bd90ab820de7aa9b436f19de7c7e225b24ed
SourceStamp 73f37c7a3860
BuildID 20131012040206
Version 27.0a1

STR:
1. Settings | Sound | Ringer | Select from Music
2. Pick a song from the music app and start playing it.
3. Select the widget in the upper right to set that song as your rington

Expected: it would be set
Actual: Many times the Settings or Music app crashes. The crash reporter comes up but I cannot seem to get a report in my File Directory.

The other result is that the UI often becomes frozen and says "Saving Ringtone."

Logcat attached during one Settings crash.
Darn. I tested on a Unagi.  And I think I was running aurora not m-c.  I'll take this bug to investigate. If it is a gecko issue, though, I'll have to assign it to someone else.
Assignee: nobody → dflanagan
I was only able to repro this issue on full songs as when I tried repro with a 1 second song the ringtone was saved and a crash did not occur. Possibly related to file size/song length? Attached the 1 second song if others need it.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131014040204
Gaia: f240abf567325d486c3d0434791b1d132cfa327a
Gecko: 211337f7fb83
Version: 27.0a1
Firmware Version: 20130912

Also heads up the crash ID led me to https://crash-stats.mozilla.com/report/index/05ba3b3e-7d2a-41f3-a710-86f2c2131014 which already has a bug written against it, https://bugzilla.mozilla.org/show_bug.cgi?id=924678.
Crash Signature: [@ PR_EnterMonitor | android::OmxDecoder::NotifyDataArrived(char const*, unsigned int, long long)]
I might be related to Bug 924678.
Can someone please try again in today's build?  (based on comment 3, and also seeing the same signature)
Keywords: qawanted
QA Contact: ktucker
This issue reproduces on the latest Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131015040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/febfe3c7732b
Gaia: 17e871ae1f82699793e3cd28acda805ba724a8b6
Platform Version: 27.0a1

A crash occur when setting a song as a ringtone.

The crash signature is not the same one that is in comment 3.

Here is the crash signature:

Crash Signature:[@ nsSimpleURI::Release() ]

Crash Report: 

https://crash-stats.mozilla.com/report/index/51122858-0cb5-4404-a691-b513e2131016

Unable to get a logcat on this since i cannot set the music ringtone while plugged into the computer.
Keywords: qawanted
QA Contact: ktucker
QA Contact: ktucker
I actually just tried the latest build and I wasn't able to reproduce on my 2 devices with a variety of different tracks:

Gaia   17e871ae1f82699793e3cd28acda805ba724a8b6
SourceStamp febfe3c7732b
BuildID 20131015040202
Version 27.0a1

I am using an earlier base image.

Can we reproduce the crash noted in Comment 5 consistently?
Using today's build I am back to crashing consistently:

https://crash-stats.mozilla.com/report/index/3344c5e4-dd54-4d39-9aae-b7d7e2131016
https://crash-stats.mozilla.com/report/index/82a9b454-1105-491f-81b1-d7cf22131016

Signature is different from the one in Comment 5: [@ android::OmxDecoder::Init(android::sp<android::MediaExtractor>&) ]

Gaia   3d4f1107e6e91e5f5649edc0f2565ac837111d7d
SourceStamp 9f63bbc00527
BuildID 20131016040202
Version 27.0a1
ktucker, that is a different crash and should probably file a separate bug.  that is happening under the settings app.

comment 7 has a separate crash as well...   I think this particular crash is a dup.  ktucker, can you file a new bug for the crash you see please?
Flags: needinfo?(ktucker)
I cannot reproduce the issue with today's version on either Unagi nor Bury with the attached MP3 file.

Gecko: m-c 423b9c30c73d
Gaia: 048728353a4739b982dbd0bc617618f4656475b3
Blocks: 927884
I am following the exact same steps as this issue though. I am going through the settings app to get this crash to occur. 

STR

1. Tap on the "Settings" icon.
2. Tap on "Sound".
3. Tap on "Change" under "Ringer".
4. Tap on "Music".
5. Tap on a "Song".
6. Tap "Play" to play the song.
7. Tap the icon in the top right corner of the screen to save the song as the ringtone.

Notice that a crash will occur.

Signature: nsSimpleURI::Release()

https://crash-stats.mozilla.com/report/index/609d8eb6-d9be-450c-9cc5-2b20f2131018

Environmental Variables
Device: Buri 1.3.0 Mozilla RIL
Build ID: 20131012040206
Gecko: http://hg.mozilla.org/mozilla-central/rev/73f37c7a3860
Gaia: e0f8bd90ab820de7aa9b436f19de7c7e225b24ed
Platform Version: 27.0a1
Flags: needinfo?(ktucker)
ktucker, this bug is about the crash signature of : [@ PR_EnterMonitor | android::OmxDecoder::NotifyDataArrived(char const*, unsigned int, long long)]

You're not hitting that crash, you're hitting a different crash if your crash id is correct; also you're on an older build.  Please update and file a separate bug.
Flags: needinfo?(ktucker)
I could not reproduce the crash on the latest 10/21 Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131021040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/7823e2985daf
Gaia: e10553a9099545157636a057c170c77fb4cb93a5
Platform Version: 27.0a1


This issue reproduces on 10/14 on Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131014080339
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab8e70fb76a8
Gaia: 74e7e69d98206bda5c517c0ada57d43de662913e
Platform Version: 27.0a1

Settings will crash after setting a song as a ringtone.


This issue does not reproduce on the 10/15 Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131015040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/febfe3c7732b
Gaia: 17e871ae1f82699793e3cd28acda805ba724a8b6
Platform Version: 27.0a1

The user can set a song as a ringtone through settings without a crash occurring.


The new issue has been written up and linked to this issue.

https://bugzilla.mozilla.org/show_bug.cgi?id=929029
Flags: needinfo?(ktucker)
See Also: → 929029
Keywords: crash
Whiteboard: [b2g-crash]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924678
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.