Cannot access to calendar data after updating Thunderbird to version 24.0.1 (Linux, German, 64 bit)

RESOLVED DUPLICATE of bug 925823

Status

--
critical
RESOLVED DUPLICATE of bug 925823
5 years ago
5 years ago

People

(Reporter: michael.schomacker, Unassigned)

Tracking

Lightning 2.6
x86_64
Linux

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 816326 [details]
tb_24-0-1_error_opensuse_12-1.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 2013091200

Steps to reproduce:

I updated my Thunderbird version from 24.0 to 24.0.1 using the Mozilla OBS (Linux, openSUSE 12.1, German localization, 64 bit). The lightning version 2.6 has been kept. My local.sqlite calendar database hasn't been changed as well.


Actual results:

After starting Thunderbird a popup window was shown (please have a look at the attached file):

"Beim Bereitstellen des Kalenders mit der Adresse moz-abmdbdirectory://abook.mab ist ein Fehler aufgetreten. Er wird nicht verfügbar sein."

Translation: An error occurred while providing the calendar with the address moz-abmdbdirectory://abook.mab. It won't be available.

Description:
[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/michi/.thunderbird/h1oy27mz.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: _calIcalCreator/< :: line 22"  data: no]

Error Code: 0x80570015

According to the message above the error occurred in line 22 of calUtils.js:
let thing = Components.classes[cid].createInstance(iid);

Context:
/* HACK: Loading calUtils.jsm here is a hack and should be fixed asap. If you
 * see this here after Lightning 2.6, please drop everything and make it go
 * away. See bug 902916 for details.
 */
Components.utils.import("resource://calendar/modules/calUtils.jsm");

function _calIcalCreator(cid, iid) {
    return function(icalString) {
        let thing = Components.classes[cid].createInstance(iid);
        if (icalString) {
            thing.icalString = icalString;
        }
        return thing;
    };
}

I was able to reproduce the error with the latest official binary of Thunderbird as well:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/24.0.1/linux-x86_64/de/thunderbird-24.0.1.tar.bz2

Now I am not able to access my calendar data and tasks anymore (the corresponding views are empty).


Expected results:

I expected that my calendar data would be accessible after the update.
(Reporter)

Updated

5 years ago
Severity: normal → critical
OS: All → Linux
Hardware: All → x86_64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925823

Comment 2

5 years ago
I don't think this is a duplicate of bug 925823, but rather the problem outlined at https://blog.mozilla.org/calendar/2013/10/dont-upgrade-to-thunderbird-24-0-1-yet/

Workaround:

If you are using Thunderbird 24.0 on Linux you MUST continue to use Lightning 2.6.
If your Thunderbird already updated the add-on to 2.6.1, download the 2.6 version from https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-2.6 and install it as follows:
1. In Mozilla Thunderbird, open the Add-ons Manager
2. From the options button next to the add-on search field, select "Install Add-on From File..." and locate the downloaded add-on.
To avoid Thunderbird to get 2.6.1 again, disable automatic updates for this plugin. Remember to turn automatic updates for Lightning back on once you update to a Thunderbird version where this bug is fixed.

If you are using Thunderbird 24.0.1 on Linux, you MUST use Lightning 2.6.1 , which Thunderbird should now install automatically if you didn't disable automatic updates. If you have automatic updates disabled for this add-on, choose "Find updates" from the context menu of the "Lightning" entry in the Add-ons Manager. If that doesn't allow you to install the update, you can also get it from https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-2.6.1

@Stefan Sitter: If you agree, please change this issue's status accordingly. (I'm new on this issue tracker and haven't got the "Can edit all aspects of any bug" permission, yet.)
You need to log in before you can comment on or make changes to this bug.