Closed Bug 926181 Opened 6 years ago Closed 5 years ago

Thunderbird 24 OSX freezes on startup with profile on network drive (AFP)

Categories

(Thunderbird :: OS Integration, defect, critical)

24 Branch
x86
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: len, Unassigned)

References

()

Details

(Keywords: hang, perf, regression, Whiteboard: [regression:TB24.0][gs][WFM:TB31][FIXED by bug 918612])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

I keep my Thunderbird profile folder on a network drive so that I can access my mail from any of my networked computers. This has worked up through version 17.0.8, but version 24 breaks it. Thunderbird freezes on startup. I tried creating a new profile through the profile manager but the problem persists.

Software: OSX 10.8.2 on network and remote computers.


Actual results:

Thunderbird freezes after startup. I can see all my mail folders but when I try to access them it freezes.


Expected results:

Up through version 17, Thunderbird functions normally.
L,
Is this on AFP?
Is problem gone if you revert to version 17?

similar issue reported at https://getsatisfaction.com/mozilla_messaging/topics/problem_with_update_24_0_1_on_osx_10_6_8_and_profile_on_afp_server
Flags: needinfo?(len)
Yes, everything including the server is running OSX 10.8.2, with all the networking handled through OSX. Going back to version 17 resolves the issue. I reproduced this on three separate machines. I agree that the issue you reference appears to be the same problem.
Flags: needinfo?(len)
Can you do a quick binary search of https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/ to find which beta between 18 and 24 the problem first appears?
Severity: normal → critical
Flags: needinfo?(len)
Whiteboard: [regression:TB??][gs]
I checked realeases from 18b1 to 23b1 and all are ok.
Trying to update to next release form 23b1 reproduced the issue.
My profile is on a Synology NAS (AFP protocol).
Flags: needinfo?(len)
coincidentally, I have a Synology NAS. But I don't know when I'd get to test it - and I don't have a Mac

Didier, thanks for that excellent info. 

Can you determine an even finer grained regression range?  A 1-2 day regression range would be awesome.  The process is to use binary search http://garykwong.wordpress.com/2009/02/24/howto-find-regression-windows-through-manual-binary-search/  - you might start roughly at https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2013/07/ which is TB24a2
Whiteboard: [regression:TB??][gs] → [regression:TB24b?][gs]
I checked the 1st build of July directory and it didn't work. So, i go through June.

OK     : Index of /pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-01-03-11-08-comm-central
NOT OK : Index of /pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-11-03-07-28-comm-central

I hope it will help to find the regression....
Thanks. Can you narrow further?  2 or 3 more tests should do it.

If we only had to check thunderbird code it might be sufficient, but I don't see anything in http://hg.mozilla.org/comm-central/pushloghtml?startdate=2013-06-01%2004:00:00&enddate=2013-06-11%2005:00:00 ...

so we need to check core checkins, and there are too many in a 10 day range http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-06-01%2004:00:00&enddate=2013-06-11%2005:00:00
I've found the first "looping" release:

/pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-07-03-11-00-comm-central

(/pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-06-03-06-40-comm-central is OK)

If i've understood the change tracking, i guess it should be: http://hg.mozilla.org/comm-central/rev/0c54a5703d29
Am i the only one to have this issue ? Is there any solution available ?
I confirm that I see exactly the same problem symptoms.
We are on 10.8.4 iMacs running off a 10.6.8 server.
The problem happens to only one of my 20 users.
The problem did not happen in 17.
When I roll the user back to 17 aok.
When I update her to 24.. nok. It already blocks up just checking the plugins. Required a kill order.

Moving the ~/Library/Application Support/Thunderbird folder to a local drive (as opposed to leaving it on the network drive which is the user's home folder) and creating a symbolic link from ~/Library/Application Support/Thunderbird---> fixed the symptoms.
But BEURK. Now that user can no longer use other workstations.
(In reply to Didier from comment #8)
> I've found the first "looping" release:
> 
> /pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-07-03-11-00-comm-central
> 
> (/pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-06-03-06-40-comm-
> central is OK)
> 
> If i've understood the change tracking, i guess it should be:
> http://hg.mozilla.org/comm-central/rev/0c54a5703d29

If http://hg.mozilla.org/comm-central/rev/0c54a5703d29 is from the failed version, what then is the source build link of the *working* THunderbird Help | troubleshooting | about:buildconfig?
Flags: needinfo?(len)
Are you asking for the build of my working Thunderbird version? I'm not sure where to find this. The version is 17.0.8.
Flags: needinfo?(len)
I thought I wrote it precisely

Help | troubleshooting | about:buildconfig?
This sounds suspiciously familiar:
   http://support.mozilla.org/en-US/questions/973417
(In reply to Jim Constantine from comment #14)
> This sounds suspiciously familiar:
>    http://support.mozilla.org/en-US/questions/973417

Thanks for that link. It ultimately leads us to bug 918612 which unfortunately, to date, won't get uplifted to Thunderbird 24 per bug 918612 comment 115.  So affected users are:
- stuck waiting til Thunderbird 31 ~August 2014 
- stuck waiting to get the patch into ESR 24.
- stuck on 2013-06-06 nightly build or TB23beta

Please test TB23beta https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/23.0b1/mac/ and confirm that it works better, so we know for sure the diagnosis above is correct or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(len)
Flags: needinfo?(didier.andre)
Keywords: perf
Duplicate of this bug: 953383
I confirm. 23.0b1 mac was the last working release.
Flags: needinfo?(didier.andre)
Are we able to pull mozilla-central patches into out TB24 ESR that are not in mozilla-central ESR 24?
I have no additional elements, I'd only add that I'm in the same boat with Didier... 
Since I found this page I reverted to 23.0b1 and things seem to work, but it would be nice to have a stable release patched since I use TB on a daily basis.

Thanks!
There is movement today in bug 918612, so odds look good for getting this in ESR with no action needed here in this bug.  
Making dependent, not duping (for now).
Depends on: 918612
Flags: needinfo?(len)
Whiteboard: [regression:TB24b?][gs] → [regression:TB24.0][gs]
Just checked, and with my setup the bug looks fixed in 24.3.0 (maybe even earlier) stable build.
Can anyone else confirm? Thanks.
24.3.0 still does not work for me.
(In reply to Lorenzo Orlandi from comment #21)
> Just checked, and with my setup the bug looks fixed in 24.3.0 (maybe even
> earlier) stable build.
> Can anyone else confirm? Thanks.

Didier, Jim, is newer version better for you?
Flags: needinfo?(jgc)
Flags: needinfo?(didier.andre)
Version 31.0 is working normally for me.
(In reply to L Flier from comment #24)
> Version 31.0 is working normally for me.

Nice. Nothing else changed?  Profile is still in AFP?

Jim, didier, do you agree?
Flags: needinfo?(len)
Summary: Thunderbird 24 OSX freezes on startup with profile on network drive → Thunderbird 24 OSX freezes on startup with profile on network drive (AFP)
Version 31 works for me with exactly the same setup as before. Thanks to everyone!

I've since discovered that a simpler way of keeping mail synced between computers is to use IMAP instead of POP. I should have switched over long ago but I had a ton of messages that I wanted to keep. Now that everything is on the server at the ISP I'm a happier camper, and so far Thunderbird is doing the job very nicely.
Flags: needinfo?(len)
Yes ! I can confirm that Version 31 is also working again for me...Don't know exactly what release solved the issue..but our Thunderbird profiles are still stored on a Synology NAS...
Flags: needinfo?(didier.andre)
Unfortunately, I no longer have access to a Mac OS X server environment to test this on.
Flags: needinfo?(jgc)
Thanks for the updates. bug 918612 got fixed in 27, so perhaps that's what helped. 
=>WFM
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [regression:TB24.0][gs] → [regression:TB24.0][gs][WFM:TB31]
Didier, L Flier, thanks for all your testing and investigations.
I think we can be certain of both the cause (bug 878411 starting in version 24) and the fix (bug 918612)
Blocks: 878411
No longer depends on: 918612
Resolution: WORKSFORME → FIXED
Whiteboard: [regression:TB24.0][gs][WFM:TB31] → [regression:TB24.0][gs][WFM:TB31][FIXED by bug 918612]
You need to log in before you can comment on or make changes to this bug.