pasting into quoted message does not paste at intended location

VERIFIED DUPLICATE of bug 57913

Status

P3
normal
VERIFIED DUPLICATE of bug 57913
17 years ago
10 years ago

People

(Reporter: blizzard, Assigned: anthonyd)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [paste])

(Reporter)

Description

17 years ago
Build is from Jul 27, 2001.

If you try to paste at the end of or in the middle of a quoted message a lot of
the time the pasted text will end up on a previous line, sometimes at the very
beginning of the message.
Steps to reproduce:

Send yourself a piece of email to reply to.  Make sure that you type it in so
you get long lines instead of just cutting and pasting it.  Here's the test that
I'm using:

[snip]

This is a test.  It includes really long sentences.  It includes really long
sentences.  It includes really long sentences.  It includes really lon sentences.

It includes really long sentences.  It includes really long sentences. It
inclues really long sentences.  It includes really long sentences. It includes
really long sentences.

[snip]

Reply to the message.

Try to paste a url from the url area in a browser window into the space in
between the two paragraphs, after the caret from the reply.  It will usually end
up on the previous line after the end of the last sentence.

It should end up after the caret for the otherwise empty line.

Comment 1

17 years ago
Is this with middle-mouse pasting, or with the keyboard?
For middle mouse, the editor gets the mouse location with
nsIDOMNSUIEvent::GetRangeParent, so it's possible that the event code might have
broken.
There was also a bug a while ago in the plaintext edit rules where inserted text
(including pasted text) would appear at the wrong place (which would affect
keyboard pasting as well as middle-mouse), but I think Joe fixed that (I had
been seeing it all the time, then stopped seeing it after his checkin) and I
think that only applied to text controls, not plaintext editing windows.

Comment 2

17 years ago
I see this all the time, and it's by far the most annoying bug I've found.

I can easily reproduce my problem by bringing up an empty compose window,
highlighting some text in an xterm, and then middle-click pasting it into
the compose window.

It seems to paste in a few lines above where my mouse pointer is. Moving the
text cursor around has no effect on the problem.

If I try to paste into the middle of a document it generally works perfectly.
It's only when I try to paste below the end that it gets confused.

I'm running 20010730 on Solaris 8.
reassign to editor team
Assignee: ducarroz → beppe

Comment 4

17 years ago
another one of those annoying paste bugs -- assigning to jfrancis
Assignee: beppe → jfrancis
Priority: -- → P3
Whiteboard: [paste]
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
This really sounds like a dup of the "middle-mouse paste is wonky" bug on
anthonyd's plate. Reassigning to anthonyd for verification.
Assignee: jfrancis → anthonyd
(Reporter)

Comment 6

17 years ago
*** Bug 80476 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 57913 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
verified as dup 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.