searching for an unset tracking flag fails since BMO upgrade on 2013-10-12

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: glob)

Tracking

Production

Details

(Reporter)

Description

5 years ago
Post the BMO upgrade on 10/12/2013, I noticed some of my saved searches are no longer returning any bugs on the query. Example queries that are failing:

- Titled - B2G Non-Nominated Regressions
** Looks for keywords = regression, Product = Boot2Gecko, Resolution = ---, blocking-b2g = ---

- Titled: B2G QA Triage - Low Priority
** Looks for Product = Boot2Gecko, blocking-b2g = ---, keywords = qawanted or steps-wanted or regressionwindow-wanted or testcase-wanted, status-b2g18 = ?, status-b2g18-v1.0.1 = ?
(Reporter)

Updated

5 years ago
Keywords: dataloss
(Assignee)

Comment 2

5 years ago
prior to the migration, unset fields had a value of '---' in the bugs table, now they simply don't have an entry in a different table.

we need to convert searches for '---' to 'isempty'; working on a fix now.
Summary: Many saved searches are broken post BMO upgrade on 10/12/2013 → searching for an unset tracking flag fails since BMO upgrade on 10/12/2013
(Assignee)

Comment 3

5 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified Bugzilla/Search.pm
modified extensions/TrackingFlags/Extension.pm
Committed revision 9062.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Summary: searching for an unset tracking flag fails since BMO upgrade on 10/12/2013 → searching for an unset tracking flag fails since BMO upgrade on 2013-10-12
(Assignee)

Comment 4

5 years ago
this has been pushed to production; the queries appear to be returning valid results now.
You need to log in before you can comment on or make changes to this bug.