Potential APK installation from web?

RESOLVED DUPLICATE of bug 766359

Status

()

RESOLVED DUPLICATE of bug 766359
5 years ago
5 years ago

People

(Reporter: rom, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130917 Firefox/17.0 Iceweasel/17.0.9 (Nightly/Aurora)
Build ID: 20130917135315

Steps to reproduce:

With Firefox 24 for Android on Cyanogen 10.1.3, I was just browsing the web on saturday 12 october (I had several open tabs, I don't know what website was involved).
The APK installation from unknown sources was enabled.


Actual results:

I saw a toast "Application installée" (in French, maybe "Installation complete" or "Application installed" in English), without any reason.

This morning, I discussed that issue with a colleague, and he said it had seen the same unexpected toast several days ago, while he was browsing using Firefox 24 on Android.

I cannot provide more information nor reproduce the problem, but it seems very suspicious.

After that, I wiped my phone and reinstall a fresh Cyanogen, and do not authorize installation from unknown sources (I uncheck/recheck when I need to install an apk).
Thanks for the report! By "toast", did you mean a message like this, http://i.imgur.com/QjD7MV5.png, or a screen like this, http://i.imgur.com/ranXyeP.png ?
(Reporter)

Comment 2

5 years ago
The first one.
If you learn what exact sites you were visiting, and what steps might be involved to reproduce, please let us know and we'll investigate that further.
The installation is complete message happens on completing an extension install. It will show up in whichever current tab you have open.

Do you have any extensions installed? Can you recall initiating an extension install during that session?
(Reporter)

Comment 5

5 years ago
I had only 1 extension installed (AdBlockPlus), but it was installed a long time ago (with my Firefox installation, several months ago). I did not install any extension in that session.
There is not anything sensitive in this bug opening to get more eyes on it.
Group: core-security

Comment 7

5 years ago
"Installation complete" pops up when an extension auto-updates.
This popup will be disabled in Firefox 25.
bug 766359
Ah that seems like the most likely reason. I had tried to reproduce that behavior on the trunk by installing an out of date extension but since 766359 was fixed I was unable to.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766359
You need to log in before you can comment on or make changes to this bug.