save password text is disappear for the password dialog for ONLY FIRST time Launch new profile.

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: huang, Assigned: jag-mozilla)

Tracking

(Depends on: 1 bug, {regression})

Trunk
mozilla0.9.6
x86
All
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
used 07-27-11-0.9.2 build

save password text is disappear for the password dialog

1) Login to an Mail account
2) Actual Results: Note the save password text is disappear for the password
dialog

Expected results: Should display "Use Password Manager to remember this
password" for the password dialog.
(Reporter)

Comment 1

18 years ago
This is ONLY occurring for the FIRST time launch for the new profile....
Summary: save password text is disappear for the password dialog → save password text is disappear for the password dialog for the FIRST time Launch for new profile.
(Reporter)

Updated

18 years ago
Summary: save password text is disappear for the password dialog for the FIRST time Launch for new profile. → save password text is disappear for the password dialog for ONLY FIRST time Launch new profile.
(Reporter)

Comment 2

18 years ago
Adding pp for the keywords since problem is not occurring for the window 
platform
Keywords: pp
(Reporter)

Comment 3

18 years ago
Removing pp since problem is also occurring on Windows.
And please note that this problem will occur after user remove mozilla directory
for the brand new profile.....
Keywords: pp
(Reporter)

Comment 4

17 years ago
Nominating nsBranch since users won't feel good with the blank text for the 
login dialog as following attach screen shot.
Keywords: nsBranch
(Reporter)

Comment 5

17 years ago
Created attachment 45122 [details]
Attach the screen shot for the blank text login dialog

Updated

17 years ago
Keywords: regression
OS: Linux → All

Updated

17 years ago
Blocks: 99230

Comment 6

17 years ago
this seems to be working for me now. Karen can you retry? If it works now, let's
mark it works for me and get if off the nsBranch radar. Otherwise I think I need
to nsBranch+ this bug. 
(Reporter)

Comment 7

17 years ago
I still seeing this problem on the current branch 09-12-05-0.9.4 build.
But it is occurring intermittently....sometimes time happen, sometimes not....
And there was bugscape 6020 
logged http://bugscape.netscape.com/show_bug.cgi?id=6020

Updated

17 years ago
No longer blocks: 99230

Comment 8

17 years ago
minusing for now. I just don't see this at all anymore. If you see it with high
regularity then we need to revist this. 
Keywords: nsbranch → nsbranch-
(Reporter)

Comment 9

17 years ago
I am still seeing this problem on Linux 09-17-05-0.9.4 build when creating new 
profile......

Comment 10

17 years ago
Branch build 2001-10-02-05: WinMe, still a problem in a new profile
Branch buid 2001-10-02-03: Mac 9.1, still a  problem in a new profile
(Reporter)

Comment 11

17 years ago
Based on my testing, above Ninoschka comments & above Scott's comments:

>minusing for now. I just don't see this at all anymore. If you see it with high
>regularity then we need to revist this. 

I am wondering to know whether there is possibility for fixing this bug for 
nsbranch since users definitely will see this after they remove mozilla 
directory for the brand new profile.....
(Reporter)

Updated

17 years ago
QA Contact: esther → olgam
(Reporter)

Comment 12

17 years ago
Renominating nsBranch since this is so obviously on UI and without this 
fix, users definitely will see this.... 
Keywords: nsbranch- → nsbranch

Comment 13

17 years ago
loks like a good one to take. what are the chances we can get this in before friday?

Updated

17 years ago
Whiteboard: [Need ETA] [PDT]

Comment 14

17 years ago
This morning I saw this problem for AOL account in existing profile with 
multiple accounts.
(Reporter)

Comment 15

17 years ago
Created attachment 52068 [details]
"Save password text is disappear for the password dialog" is still existing on today's build

Comment 16

17 years ago
Actually jag's been working very hard trying to come up with a fix to common
dialogs.xul for us. I'm going to re-assign this to him since it isn't a mail
specific fix anyway. We'll keep an eye out and if he can cook something good up
for us, I'll take it to PDT.
Assignee: sspitzer → jaggernaut

Updated

17 years ago
Keywords: nsbranch → nsbranch+
(Assignee)

Comment 17

17 years ago
So after some tinkering I've found out that the XBL binding for the checkbox 
doesn't get attached until after onload is done, meaning that any code that 
depends on checkbox's methods and properties (e.g. .label, .checked) will fail. 
I think this is also the cause of the dialog not being tall enough since the 
check image (or the empty box, initially) won't be taken into account while the 
dialog is intrinsically sized.

I have an ugly work around. mscott, could you lobby for r=, sr= and a= while I 
dig deeper into why the xbl binding attach is delayed? I suspect the right fix 
to be more involved that what we'd take for 0.9.5.
(Assignee)

Comment 18

17 years ago
Created attachment 52094 [details] [diff] [review]
Work around missing label and incorrect height.

Comment 19

17 years ago
Comment on attachment 52094 [details] [diff] [review]
Work around missing label and incorrect height.

sr=mscott

I'll find someone to put an r= in this work around. Thanks jag!
Attachment #52094 - Flags: superreview+

Comment 20

17 years ago
adding to tracker bug.
Blocks: 99508
Comment on attachment 52094 [details] [diff] [review]
Work around missing label and incorrect height.

r=sspitzer

make sure to test on all platforms, I remember bugs before where sizeToContent() did unexpected things (on linux, I think).
Attachment #52094 - Flags: review+

Comment 22

17 years ago
pls check this into the branch - PDT+, pending linux testing out ok.
Whiteboard: [Need ETA] [PDT] → [Need ETA] [PDT+] fix for 094 branch
(Assignee)

Comment 23

17 years ago
Where "unexpected things" == "crash the product".

I've tested on Linux, it works fine there. Can someone test this on Mac for me?

The only disadvantage to this patch is that the resize is visible (one can see
it grow to the larger state) in this one case. Normally the dialog pops up at
the right size so that a resize can't be noticed.

Comment 24

17 years ago
well i guess I'd rather have the penalty of seeing the resize that first time
than having the dialog look the way it does now.

Jag, can you check this into the branch tonight? If you can't, I can check it in
for ya.

Comment 25

17 years ago
*** Bug 81442 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
When will this fix be in the trunk or the branch?

Comment 27

17 years ago
hey jag, I don't know if you saw my earlier question but can you check this into
the branch ASAP? If not, I can do it for ya! Thanks.
(Assignee)

Comment 28

17 years ago
I checked it in last night (well, early this morning), forgot to mention that
here.
(Assignee)

Comment 29

17 years ago
Checked it in on the branch 0.9.4, that is.

Updated

17 years ago
Whiteboard: [Need ETA] [PDT+] fix for 094 branch → [Need ETA] [PDT+] FIXED on 094 branch

Updated

17 years ago
Keywords: vbranch

Comment 30

17 years ago
nothing to see here. adding vbranch keyword since this is in the 094 branch.
Thanks for checking it in this morning jag.

Comment 31

17 years ago
Branch build 2001-10-05-05: WinMe, fixed

Branch build 2001-10-05-03: Mac 9.1, not fixed.
Branch build 2001-10-05-04: Linux RH 7.1, not fixed.
Did the fix make it into the Mac and Linux builds?

Updated

17 years ago
QA Contact: olgam → nbaca
(Reporter)

Comment 32

17 years ago
Yes. After I remove mozilla directory for creating some new profiles for testing 
this bug:
I have the same results with Ninoschka:
This fixed on Windows, but not fix on Linux and Mac platforms yet....
(WinNT 10-05-05-0.9.4, Linux 10-05-04-0.9.4 & Mac 10-05-03-0.9.4 builds)
(Assignee)

Comment 33

17 years ago
Hmmm... This is in cross platform code, I don't know why linux and mac didn't
pick it up. I tested it on all three platforms, saw the bug on all three, and
saw my fix work on all three.

Updated

17 years ago
Whiteboard: [Need ETA] [PDT+] FIXED on 094 branch → [PDT+] FIXED on 094 branch
(Assignee)

Comment 34

17 years ago
Ninoschka: does this work on Mac and Linux now?

Comment 35

17 years ago
Branch build 2001-10-08-03: Mac 9.l, Mac X
Branch build 2001-10-08-04: Linux RH 7.1
It appears ok on these branch builds (in a new profile I created an IMAP
account, and in another new profile created a POP account).
(Assignee)

Comment 36

17 years ago
I had to back out (on the 0.9.4 branch) the fix for the vertical sizing problem
since that caused other problems. The underlying problem is bug 103928, which is
hard to fix, and any work-around would have to be done in commonDialog.js, which
makes it easy to cause other highly visible problems (as shown by my previous
work-around). In short, I suggest we look at bug 103928 for the trunk, and keep
0.9.4 as it is.

The good thing about all this is that at least the checkbox label shows up now
and is correctly checked/unchecked.
Depends on: 103928

Comment 37

17 years ago
thanks for trying jag. Taking off the branch+ radar and the PDT radar since we
won't be taking a fix for 103928 on the branch.
Keywords: nsbranch+, vbranch
Whiteboard: [PDT+] FIXED on 094 branch
Target Milestone: --- → mozilla0.9.6

Comment 38

17 years ago
removing obsolete dependency.
No longer blocks: 99508

Comment 39

17 years ago
Marking nsbranch because the Password dialog still appears cutoff.

Branch build 2001-10-10-05: WinMe
In a new profile when Mail starts if the first dialog that appears asking if you
want Netscape6 to be the default, then the password dialog appears ok. If
Netscape6 is already the default then the first dialog to appear is the password
dialog, and the dialog appears cutoff but the text is present. 
Workaround: I can't resize the dialog but if I close and then Get Messages again
then the password dialog appears ok. 

Branch build 2001o-10-10: Mac 9.1, Linux RH 7.1
The password dialog is also cutoff on the mac and linux as well.

In all cases if the Webmail is activated in a new profile then the password
dialog is ok.
Keywords: nsbranch

Comment 40

17 years ago
hey ninoshcka, we had had our chance to fix this bug last week and it ended up
making things worse. While it looks ugly this is no longer in the stop ship
category and that's why I took it off the radar. Putting back the minus. Sorry =(
Keywords: nsbranch → nsbranch-

Comment 41

17 years ago
i think we want to leave the nomination for MailNews team to + or -. Putting
back nsbranch, and marking [PDT-] for 094. Sorry for the spam, but I want to
preserve the work the teams have already done in their triage.
Keywords: nsbranch- → nsbranch
Whiteboard: [PDT-]

Comment 42

17 years ago
doh! Sorry, missed marked a bug. Returning this to the pristine mscott marking
of nsbranch-.
Keywords: nsbranch → nsbranch-
Whiteboard: [PDT-]

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-
(Assignee)

Comment 43

17 years ago
It looks like this has been fixed with some related bug that hyatt fixed
recently.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 44

17 years ago
Trunk build 2002-03-01: WinMe, Linux RH 7.1, Mac 9.1
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.