versionbump.py writes diffs with CRLF line endings on Windows

REOPENED
Unassigned

Status

Testing
Mozbase
--
minor
REOPENED
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Trunk
All
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We should be doing something like:
http://stackoverflow.com/questions/2536545/how-to-write-unix-end-of-line-characters-in-windows-using-python
(Reporter)

Updated

4 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED
(Reporter)

Comment 1

4 years ago
versionbump.py no longer exists after bug 949600.
Assignee: emorley → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
I don't think we should get this bug closed. Instead get it ported via bug 974184 for hg.m.o.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 3

4 years ago
Agreed, but this will happen in bug 974184 now; duping there.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974184
(Reporter)

Comment 4

4 years ago
Actually not this one; we won';t be writing diffs any more.
Resolution: DUPLICATE → WONTFIX
Well, we would write diffs in terms of bug 831499. So it should block that bug.
Blocks: 831499
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Depends on: 974184
No longer blocks: 831499
You need to log in before you can comment on or make changes to this bug.