searching for tracking flags is broken for negated terms where values are unset, breaking the leo+ b2g triage query

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: TrackingFlags
--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: glob)

Tracking

Production

Details

Comment 1

4 years ago
Guys, we need to jump on this. We are doing near daily triage of these bugs to keep the b2g 1.2 work on track.

Hopefully it will be a quick fix.
Severity: normal → blocker
Flags: needinfo?(glob)
Flags: needinfo?(dkl)
(Assignee)

Updated

4 years ago
Assignee: nobody → glob
Component: Administration → Extensions: TrackingFlags
Flags: needinfo?(glob)
Flags: needinfo?(dkl)
OS: Gonk (Firefox OS) → All
Hardware: ARM → All
(Assignee)

Comment 2

4 years ago
ah, the problem is when we moved to rows, unset values are no longer present in the database, so return NULL to the query's operators.  INSTR on NULL doesn't work.

wrapping the values in COALESCE results in the following buglist:

bug 895739
bug 900326
bug 903279
bug 908581
bug 911716
bug 914942
bug 915645
bug 920639
bug 923473
bug 924383

which looks correct.


working on a code fix now.
(Assignee)

Comment 3

4 years ago
fix committed:

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/TrackingFlags/Extension.pm
Committed revision 9064.

will get this pushed to production asap.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: leo+ B2G Triage bug query is returning zero bugs on search, even though there are leo+ bugs present post 10/12/2013 BMO upgrade → searching for tracking flags is broken for negated terms where values are unset, breaking the leo+ b2g triage query
(Assignee)

Comment 4

4 years ago
this has been pushed to production, the query now returns 10 bugs.
You need to log in before you can comment on or make changes to this bug.