Closed Bug 926589 Opened 7 years ago Closed 7 years ago

[B2G][Contacts[Export] Black screen appears when tapping the previously imported contact from SIM from a search result on the export page

Categories

(Core :: Graphics, defect)

26 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 923303
blocking-b2g koi+

People

(Reporter: sarsenyev, Assigned: djg)

References

Details

(Keywords: regression, Whiteboard: burirun2)

Attachments

(4 files)

Attached video IMG_0277.MOV
Description:
When tapping on a previously imported contact from a search result, a black screen appear when trying to "check-mark" the contact for an export

Prerequisites:
Previously imported contacts from SIM

Repro Steps:
1) Updated Buri to BuildID: 20131014004003
2) Open "Contacts" app from the home screen
3) Tap the "Settings" (cogwheel) icon
4) Navigate to the "Export Contacts"
5) Choose "SIM card"
6) In the "Search bar" the letters that will match with the contact that previously imported from the SIM
7) Tap the "checkmark" from the result
8) When a black screen appears , tap the black screen again on the spot when the contacts should be

Actual:
The screen is getting black each time when tapping the check-mark on the "Export menu

Expected:
No black screen appears when check-marking the check-box 

Environmental Variables:
Device: ( Buri v1.2 Aurora Mozilla RIL)
BuildID: 20131014004003
Gaia: d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
Gecko: 690f28662ace
Version: 26.0a2
Firmware Version: US_20130912

Notes:
The issue is intermittent, may not reproduce from the first time, please try to reproduce it so;
after step 7, tap "cancel", close the "export contacts" page by tapping the "X"
Repeat from the step 4 

Repro frequency: 3/5
See attached: log, video attachement
Attached file log1.txt
Attached image wrong "export" screen
Also, when the issue occurs, go back to the "Contacts" list, "export" button appears instead of "cogwheel" (Settings) button
And on the "Export" screen, the "cogwheel" button appears instead of "export" icon but the "cogwheel" button is unclickable, see the more attachments
Attached image Wrong "Contacts" screen
Blocks: GFXB2G1.2
Component: Gaia::Contacts → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
blocking-b2g: --- → koi?
QA Contact: gbennett
Last working build ( Does NOT Reproduce)

Environmental Variables:
Device: Buri 1.2 Aurora mozRIL
BuildID: 20131001004003
Gaia: 5e0d0df6a762cf1e1812eeb735fba72e2539dc0c
Gecko: 5689e4237ab7
Version: 26.0a2
Firmware Version: 20130912
Notes: Know that this does not repro as the keyboard does not work when trying to search so I am blocked from checking. Also all builds since export was implemented have this issue until 20131002004001 (first broken).


First Broken (Reproduces)

Environmental Variables:
Device: Buri 1.2 Aurora mozRIL
BuildID: 20131002004001
Gaia: def8e152db6a317162c03a316f68c409f3af3979
Gecko: b955a00f4167
Version: 26.0a2
Firmware Version: 20130912

Unable to check on 1.1 as there is no area to export contacts that I can find.
Looking at the changes from the regression range above: http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=5689e4237ab7&tochange=b955a00f4167

Bug 914854 removed some reflows, bug 916379 removed a repaint request.  Fabrice, Kats, any chances this caused it?

Doesn't reproduce on unagi for me.
(In reply to Milan Sreckovic [:milan] from comment #5)
> Looking at the changes from the regression range above:
> http://hg.mozilla.org/releases/mozilla-aurora/
> pushloghtml?fromchange=5689e4237ab7&tochange=b955a00f4167
> 
> Bug 914854 removed some reflows, bug 916379 removed a repaint request. 
> Fabrice, Kats, any chances this caused it?

Forgot to ni :)
Flags: needinfo?(fabrice)
Flags: needinfo?(bugmail.mozilla)
I don't think bug 916379 would cause this; it affects only APZC codepaths and APZC is not yet enabled in the contacts app.
Flags: needinfo?(bugmail.mozilla)
From the following in attachment 816735 [details], it seems to related to out of pmem problem.

> E/memalloc(138): /dev/pmem: No more pmem available
> E/msm7627a.gralloc(138): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(138): alloc(320, 460, 2, 00000133, ...) failed -12 (Out of memory)
> W/Adreno200-ES20(138): <qgl2DrvAPI_glTexSubImage2D:550>: GL_INVALID_OPERATION
Bug 914854 is only dealing with reflows while scrolling, so I doubt this is the cause here. Doing a build with a backout of this patch is easy though if it's not the pmem issue that Sotaro points out.
Flags: needinfo?(fabrice)
Sotaro,

Based on :fabrice input, please suggest next steps for the fix.

Also, what about be the user impact if this fix was not uplifted?
Flags: needinfo?(sotaro.ikeda.g)
Is there anybody else that can back out those patches and try things instead of asserting it's the graphics problems and passing it to Sotaro who is way past overloaded?
Flags: needinfo?(sotaro.ikeda.g)
Ben,

Can you please help with the back out?

This is a blocker.
blocking-b2g: koi? → koi+
Flags: needinfo?(bkelly)
I can try to help, although my priority needs to be on perf issues.

So far I haven't been able to reproduce this.  The problem description and video seem similar to the issues I was previously having where I flashed the mozilla gonk instead of using the vendor gonk.  That was an issue with the pmem fallback not working properly as Sotaro suggested.  Can you confirm you are using vendor firmware?  Have we seen this issue anywhere else on vendor firmware?

Also, I ran into a separate bug with the checkbox just not working at all in v1.2 gaia.  See bug 930693.
Flags: needinfo?(bkelly)
Dan, can you do a local build with patches from bug 916379 and bug 914854 removed and see if the problem goes away?  Assuming you can reproduce it in the first place.
Flags: needinfo?(dglastonbury)
I'm starting to look at this.
Flags: needinfo?(dglastonbury)
None of my devices have SIM cards. Is that important for the STR for this bug? (I'm going to try to repro with a memory card)
Flags: needinfo?
I've not been able to reliably repro this. I'm testing on hamachi, I don't have buri, but I'm told they're identical. I don't have a SIM that's recognised by the phone, so I'm testing exporting to uSD card.

I have seen the screen go black when I tap the search bar. When I tap a checkmark, the screen returns. Sometimes the black screen will disappear after approx. 5 seconds. If that happens, I can't get the black screen to return, reliably. In logcat, I'm seeing out of Pmem errors when the black screen happens.

I'm going to try removing the patches that Milan states in Comment 14.
Assignee: nobody → dglastonbury
Flags: needinfo?
Continued investigation of this bug. Removing the patches in Comment 14 doesn't help.

Looks like the fullscreen black rendering in the contacts app coincides with a failure in glTexSubImage2D when attempting to read back the front buffer to update just part of it. My guess is that the texture isn't valid but our logic thinks it should be, so is calling TexSubImage2D instead of TexImage2D.
This bug seems a dup of Bug 923303. It is already fixed by Bug 905882. attachment 816735 [details] has '/dev/pmem: No more pmem available' in the log.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923303
Since the pmem failure bugfix went in, I've done a full flash of my device and I can no longer repro the glTexSubImage2D error I was seeing associated with this bug.

QA, can you test again with the latest v1.2?
Flags: needinfo?(gbennett)
Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131103004003
Gaia: cb981e2f47bc644b4d178d54378c3676c946facf
Gecko: eec4da1b27eb
Version: 26.0
Firmware Version: 20131015

I am unable to repro this issue on the latest 1.2. Let me know if you need any more info. Thanks. :)
Flags: needinfo?(gbennett)
You need to log in before you can comment on or make changes to this bug.