Closed Bug 92659 Opened 20 years ago Closed 18 years ago

Doesn't print news msgs with images.

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 159995

People

(Reporter: skasinathan, Assigned: mscott)

Details

Attachments

(2 files)

1. Select a news msg with images. (I tried jpeg, stephend tried with gif).
2. Click Print in toolbar. A small window appears on the right bottom of the
screen with title "printing". The native print dialog never comes up. I tried to
quit the app using Ctrl+q then the print dialog came up, but ok'ing it never
prints anything.  

stephend tried to double click the small window, the native print dialog comes
up. On ok'ing it, the app crashes. He will attach a stack trace.

NOTE: 1. I tested imap printing, it works fine (text, html, images).
2. Able to reproduce this consistently. 

Build: Today's BRANCH build on Win 2K.
Branch build 2001-07-17: WinMe
The problem also occurs on older builds so it's not specific to the 7/27 builds.
Selecting my test message in netscape.public.test on news.netscape.com and
attempting to print it kills my Mac (without bringing up Talkback).
OS: Windows 2000 → All
Hardware: PC → All
To clarify/summarize:  Sheela is running RedHat 6.2 and sees a crash on clicking
"OK" at the print setup dialog.  I'm on RedHat 7.1/Mac OS 9.1/Windows 2000.  I
don't have printing setup yet on 7.1, working on it.  Suresh, who's on Windows
2000 like me, doesn't see a crash when he OK's the print setup dialog.
stephend/nbaca: Shd this be release noted?
I've added this bug and a brief description of it to bug 90577, which is the
tracker bug for release notes.
This looks like mailnews has implemented this fuctionality incorrectly.  Normal 
printing with images works just fine, I think an implementation problem.
Assignee: dcone → mscott
Component: Printing → Mail Back End
Not being able to print a news message with an image is less than desirable ;-)
Keywords: nsbeta1
Keywords: nsbeta1nsbeta1-
bzbarsky:
Is this still an issue ? If not we can remove this bug from the release notes...
:)
No clue; someone who saw the bug originally and may have the required news
messages to hand should test.
I bet this is a dup of bug #159995, at least the summary is.

*** This bug has been marked as a duplicate of 159995 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.