[traceback] HttpClientError: Client Error 404: https://payments-dev.allizom.org/generic/product/6/

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: jkerim)

Tracking

({regression})

Avenir
regression
Points:
---

Details

(Whiteboard: [good first bug], URL)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/in-app-keys/

sentry: http://sentry.dmz.phx1.mozilla.com/addons/marketplace-dev/group/16908/

traceback details:


HttpClientError: Client Error 404: https://payments-dev.allizom.org/generic/product/6/
Content: 


Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)
  File "newrelic/hooks/framework_django.py", line 475, in wrapper
    return wrapped(*args, **kwargs)
  File "amo/decorators.py", line 157, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 149, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 32, in wrapper
    return func(request, *args, **kw)
  File "waffle/decorators.py", line 36, in _wrapped_view
    return view(request, *args, **kwargs)
  File "mkt/developers/views_payments.py", line 260, in in_app_keys
    {'key': key})
  File "jingo/__init__.py", line 80, in render
    rendered = render_to_string(request, template, context)
  File "jingo/__init__.py", line 98, in render_to_string
    return template.render(**get_context())
  File "newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)
  File "newrelic/api/function_trace.py", line 82, in dynamic_wrapper
    return wrapped(*args, **kwargs)
  File "jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)
  File "./mkt/developers/templates/developers/payments/in-app-keys.html", line 4, in top-level template code
    {% set title = _('Test In-App Payments') %}
  File "./mkt/developers/templates/developers/base_impala.html", line 8, in top-level template code
    {% set editable = "no-edit"
  File "./mkt/developers/templates/developers/skeleton_impala.html", line 115, in top-level template code
    {% block main_content %}
  File "./mkt/developers/templates/developers/skeleton_impala.html", line 118, in block "main_content"
    {% block content %}{% endblock %}
  File "./mkt/developers/templates/developers/payments/in-app-keys.html", line 32, in block "content"
    <td><input type="text" value="{{ key.public_id() }}" readonly></td>
  File "mkt/developers/models.py", line 284, in public_id
    return self._product().get()['public_id']
  File "curling/lib.py", line 137, in get
    params=kwargs)
  File "curling/lib.py", line 214, in _request
    content=self._try_to_serialize_error(resp))
Whiteboard: [contribute]
Looks like the seller product here was somehow deleted, thus this error is specific to dev. It's disturbing that it got deleted though.
Component: Developer Pages → Payments/Refunds

Updated

4 years ago
Priority: -- → P3
Target Milestone: 2013-10-14 → ---
Version: 1.0 → Avenir

Updated

4 years ago
Whiteboard: [contribute] → [good first bug]

Comment 2

4 years ago
In this scenario we'd like to catch the error and show a nice message.
(Assignee)

Updated

4 years ago
Assignee: nobody → jkerim
(Assignee)

Comment 3

4 years ago
Steps to reproduce:

[14:57:36]  <andym>	 https://marketplace-dev.allizom.org/developers/in-app-keys/
[14:58:10]  <andym>	 make an payment account
[14:58:13]  <andym>	 make an app
[14:58:21]  <andym>	 give it in app payments
[14:58:26]  <andym>	 go to that page locally
[14:58:30]  <andym>	 you should see keys
[14:58:39]  <andym>	 now delete the payment account
[14:58:42]  <andym>	 and visit the page
Status: NEW → ASSIGNED

Comment 4

4 years ago
Actually looking at the traceback its in curling. I think the deletion occurred in the matching solitude record, not zamboni.
(Assignee)

Comment 5

4 years ago
Merged in https://github.com/mozilla/zamboni/pull/1742
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.