Intermittent TEST-UNEXPECTED-FAIL | testBookmarksPage | Exception caught - junit.framework.AssertionFailedError: Text string: 'Open in Private Tab' is not found!

RESOLVED DUPLICATE of bug 899187

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 899187
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Trunk
All
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=29089160&tree=Mozilla-Inbound#error0
using slave: tegra-190


44 INFO TEST-PASS | testBookmarksPage | Checking that the context menu option is present - Add to Home Screen is present
EventExpecter: no longer listening for Tab:Added
45 INFO TEST-PASS | testBookmarksPage | waiting for urlbar text to gain focus - urlbar text gained focus
46 INFO TEST-PASS | testBookmarksPage | Checking that the correct tab is displayed - The BOOKMARKS tab is displayed
waitForText timeout on Share
Exception caught during test!
junit.framework.AssertionFailedError: Text string: 'Open in Private Tab' is not found!
	at junit.framework.Assert.fail(Assert.java:47)
	at junit.framework.Assert.assertTrue(Assert.java:20)
	at com.jayway.android.robotium.solo.Clicker.clickOnText(Clicker.java:363)
	at com.jayway.android.robotium.solo.Solo.clickOnText(Solo.java:1000)
	at org.mozilla.fennec.tests.testBookmarksPage.checkBookmarkContextMenu(testBookmarksPage.java:118)
	at org.mozilla.fennec.tests.testBookmarksPage.testBookmarksPage(testBookmarksPage.java:37)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:149)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
47 INFO TEST-UNEXPECTED-FAIL | testBookmarksPage | Exception caught - junit.framework.AssertionFailedError: Text string: 'Open in Private Tab' is not found!
48 INFO TEST-END | testBookmarksPage | finished in 123740ms
49 INFO TEST-START | Shutdown
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Blocks: 899187

Comment 6

4 years ago
Bug 899187 has been backed out, this will need to be fixed before it relands :-)
No longer blocks: 899187
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899187
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.