Intermittently, mail composer in plain text stops performing line wrap

VERIFIED DUPLICATE of bug 83378

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 83378
17 years ago
10 years ago

People

(Reporter: Peter B. West, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726
BuildID:    2001072623

Sometimes in recent (approx 3 weeks) builds, the plain text mail composer ceases
to perform line wrap.  This is usually preceded by a quirk in the newline
behaviour on empty lines, typically when inserting empty lines beneath quoted
text when replying.  I can't describe this exactly, but I think that the cursor
is displaced to an unexpected line following the entry of a newline.

After noticing this quirk, I find that line wrapping has ceased.  Closing the
mail composer and the mail window, and re-opening does not restore the line
wrapping.  Closing and re-starting mozilla does restore it.

Reproducible: Sometimes
Steps to Reproduce:
1.Reply to a message
2.Introduce a few empty lines after the quoted text, but before the signature
3.Type or paste long lines of text

Actual Results:  Cursor behaves strangely on typing of newlines for empty lines.
 I can't be sure whether the newline is inserted, but the cursor appears on the
wrong line, usually below the expected position.

long lines do not wrap at all.

Expected Results:  Newline entry inserts newline and places cursor at the
beginning of the line following the insertion.
Line wrapping is honoured.

*** This bug has been marked as a duplicate of 83378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified as dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.