spaces between differently styled pieces of text disappear when window resized

RESOLVED DUPLICATE of bug 110243

Status

()

RESOLVED DUPLICATE of bug 110243
17 years ago
17 years ago

People

(Reporter: sadvani, Assigned: attinasi)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.2+) Gecko/20010727
BuildID:    2001072703

In looking over the Debug | Viewer Demos, I decided to see how well these all
worked.  I uncovered a reproducible rendering bug as words in a paragraph are
reformatted to fit the window as it is resized.  Specifically, as the window is
grown, words that "bubble up" a line that have the "bold" attribute occasionally
will not render with the space that separates them from the previous word.

Reproducible: Always
Steps to Reproduce:
1. Select the Debug | Viewer Demos | 0 Basic Styles
2. Scroll to the bottom of the page
3. Slowly drag the left side of the window back and forth, and notice the space
between the word 'aligned' and the bolded word next to it (left, center, right).
 The space will occasionally not render.

Actual Results:  Spaces on the left-hand side of the screen fail to be inserted
between words.

Expected Results:  Correct rendering of the text.
win98, trunk 2001072603: Same problem occurs in the beginning of the page too,
in "This is a basic paragraph with <b>bold</b>, <i>italic</i>" etc...  words
clump together when the browser window is resized, like "paragraph
withbold,italic, and bold-italictext"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 43866 [details]
image showing bug at top of page
->Layout
Assignee: clayton → karnaze
Component: HTML Element → Layout
QA Contact: bsharma → petersen

Comment 4

17 years ago
Reassigning to attinasi.
Assignee: karnaze → attinasi

Updated

17 years ago
Severity: normal → minor
Target Milestone: --- → Future
resummarizing: "Justified / bold combination renders incorrectly when window
resized" -> "spaces between differently styled pieces of text disappear when
window resized". apparently spaces between differently styled pieces of text are
lost. This can be seen in bug 104864 the "Bug 104864 depends on" list. Seen in
linux 2001111202 (0.9.6 branch), os -> all
OS: Windows 95 → All
Summary: Justified / bold combination renders incorrectly when window resized → spaces between differently styled pieces of text disappear when window resized
WFM, up-to-date Linux CVS.
Bah, I can reproduce this after all.  Narrow a bug page with a bunch of
dependencies down so they all appear in a single column.  Then start dragging
the window out until they appear in two columns; space will start getting lost.
 Upping severity.
Severity: minor → normal

Comment 8

17 years ago
Should be fixed with bug 110243.

Comment 9

17 years ago
<spam>
Damn I love when a patch fixes two bugs. That's the 'cherry the on cake' :))
</spam>

Comment 10

17 years ago
Fixed by bug 110243. Marking as duplicate so that it is easy to track any 
problems from either bug.

*** This bug has been marked as a duplicate of 110243 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.